E-mail client dies when device rotated back

BUILD ID = (Settings > About product): pallas-yllästunturi
REGRESSION: Yes; prev. version showed same problem


compose mail with build in e-mail-client.
(1) device is rotated (anticlockwise) by 90 degree - screen is been updated - works well.
(2) when rotated backwards - screen shows the background image and mail-client dies with “waiting for application error”.
(3) when restarting mail-client drafts are gone. basically restart writing text again.

sometimes even small amounts of turning movements are enough to trigger this.




  1. start application e-mail
  2. start composing mail (holding device upright)
  3. turn device (into landscape mode)
  4. turn device backwards (into portrait mode)
  5. screen will not be updated; application dies.


  1. when dying - composed text should be cached
  2. any rotation or movement of the device should not kill running applications


this problem was visible in the official predecessor of as well.


there are no logs; screenshot does not work while claiming a violation of permissions

It seems that you meant to say “no” for regression?
I tired it and can’t seem to reproduce this.
Maybe try launching the email app from the terminal (jolla-email) and see if there are any log printouts when it crashes?

thank you for response.

tried to start jolla-email from the terminal … but this failed
Last login: Sat Oct 24 17:34:36 2020 from
| Sailfish OS (Pallas-Yllästunturi)
[nemo@Sailfish ~]$ /usr/bin/jolla-email -prestart
[D] unknown:0 - Using Wayland-EGL
[W] unknown:0 - DeclarativeEmailService::DeclarativeEmailService(QObject*) Failed to register com.jolla.email.ui service
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
[D] unknown:0 - Messaging : opening database
Loaded xulDir:/usr/lib/xulrunner-qt5-52.9.1, appDir:/usr/bin

the same library-not-found you see on the devices terminal … my test was over an existing ssh-connection (IMHO: should not care)

to visualize the problem please take a look video showing the problem

Did you try without the prestart flag?
It launches fine for me, also over ssh.
I do see “libxul.so is not found, in /usr/bin/libxul.so” too, so it’s probably not critical.

Maybe it needs more email accounts to happen or something, i have only one.

yes, i tried both - with and without flag. i saw this flag in the process list so guessed it could be necessary.

[nemo@Sailfish ~] find / -name \*libxul\* 2>/dev/null /usr/lib/xulrunner-qt5-52.9.1/libxul.so [nemo@Sailfish ~]

maybe a link in /usr/bin/ is missing … anyway.

BTW: in the movie you see me closing the error-message - in case it doesn’t care - when waiting or not waiting for response.

it seems the editor screen redraw got stuck.

what else could i try ? :slight_smile:

a bit more currious is the error-message at the end - when starting “jolla-email” inside a terminal - “speicherzugriffsfehler” - which means: “Segmentation fault” which leads usually to a memory-corruption

So you are saying that you can’t launch the email app from the terminal at all? That sounds really odd.
Well, eMMC storage isn’t very reliable, so reinstalling it could help restore any file that might have gotten corrupted… but it’s a bit of a longshot.

yes, i’m not able to start email-app from terminal (neither from “ssh -X” nor from a terminal on the sailfishOS-device) … in GUI jolla-email works beside the mentioned misbehaviour.

could not believe a memory corruption as md5sums for all used shared-libraries exist

[nemo@Sailfish ~]$ **md5sum /usr/bin/jolla-email** 
7ac863562f01fbd5e44960dce7278d04  /usr/bin/jolla-email
[nemo@Sailfish ~]$ **ldd /usr/bin/jolla-email | awk '{print $3}' | xargs md5sum** 
3317bdf273779351795b9fb7fef225ea  /usr/lib/libnemonotifications-qt5.so.1
97a02d5b51026e578bb993d20b309ae4  /usr/lib/libsailfishwebengine.so.1
b4c927f9af0e957c9a6f1acfea349407  /usr/lib/libqt5embedwidget.so.1
22634241e9911912bbf9e537817194f3  /usr/lib/libmdeclarativecache5.so.0
a99942c4e2a734a750e81219772b9156  /usr/lib/libQt5Quick.so.5
5aaae27fe960f42b133fa530f5311164  /usr/lib/libQt5Gui.so.5
97b787ade1374757ca6e52d84734b37d  /usr/lib/libQt5Qml.so.5
fe38a61995ea7fb9dfd13c63c5b7f11a  /usr/lib/libQt5Network.so.5
be14881bc8caa77128bd58854dfe771d  /usr/lib/libQt5DBus.so.5
ac6ee8d70f6d05f94f619feb60373a48  /usr/lib/libQt5Core.so.5
04cdaf90c3156f460f732fc2cbe6552b  /usr/lib/libGLESv2.so.2
6695fc4cdf78be724ae30d266049398a  /lib/libpthread.so.0
a776e94d250051eae798dad031778c2a  /usr/lib/libstdc++.so.6
39f0f88895062da265abb0415464b93f  /lib/libm.so.6
9ea914bc62281e3644039f9c5fc4688b  /lib/libgcc_s.so.1
dd1a4c723ea17479545766dc09e80467  /lib/libc.so.6
75c909dd90b3ddafae6991bcdebf032f  /usr/lib/libsailfishsilica.so.1
39e87856d37d849bb48b36a8ab5785f3  /lib/libdl.so.2
14d038097e9f6a43acddf507a1b2709f  /usr/lib/libsystemsettings.so.0
ccc879abb054a5656f3ed31a005c8df7  /usr/lib/libEGL.so.1
6a4ac724cc7d161fb49d2dcd26d00dbf  /usr/lib/libpng16.so.16
aa4300b0afc91f1759604e11e9eb019b  /usr/lib/libz.so.1
90658836a1dbebb322aad016f45599e6  /usr/lib/libdbus-1.so.3
ca6fda727aff784da996790222fbcd27  /usr/lib/libicui18n.so.66
2b9c355d1ede512764bdae012e32859f  /usr/lib/libicuuc.so.66
46225be7d1e88f88a6c0640e62c0e3e6  /usr/lib/libpcre16.so.0
81d774ce12b86ddcee18daf7797db226  /usr/lib/libglib-2.0.so.0
7d6d049792db594340a7dde17ce667fa  /usr/lib/libsystemd.so.0
ebb73bbf78f54f4b19093806bcc57721  /usr/lib/libhybris-common.so.1
b551ff73057b177879d2845532cb4f82  /lib/librt.so.1
a17dff73d3c5d31ceb83a85d8011cf3d  /usr/lib/libmlite5.so.0
8f3bf03d84f652f3bcc84dae10fff402  /usr/lib/libsailfishsilicabackground-qt5.so.0
d8e5ca76c0c01d6d07ef927a4cb8697f  /usr/lib/libprofile.so.0
4ae68026e4337ee423081262ffc6d438  /usr/lib/libtimed-qt5.so.0
cf161f236b56201562468e205928b1a1  /lib/libcrypto.so.10
029937c315bbb2f344abb06f3fdc1967  /usr/lib/libsailfishkeyprovider.so.1
78b0b9a00204364b0b4a8a156e55f187  /usr/lib/libconnman-qt5.so.1
82ef64e474cab83fca94ebe11d9aa587  /usr/lib/libssusysinfo.so.1
693b645862f58856152476ebd2fcc8d6  /usr/lib/libnemodbus.so.2
3dcee711281e8ac955a06b954b67869c  /usr/lib/libpackagekitqt5.so.0
9bd7357518cdbd6f479021e5d401fb71  /usr/lib/libsailfishaccesscontrol.so.0
e735fb23c2d6c0741555879b291b593a  /usr/lib/libQt5SystemInfo.so.5
2cea66c3ee44c0aa672111f4eab5cd29  /usr/lib/libhardware.so.2
35e00da0feb8f651ba4f8517f446ffe8  /usr/lib/libicudata.so.66
132869f0282c08ef57179dab25c7d004  /usr/lib/libpcre.so.1
d9fc39dd1edb2a95300d2142a5831d13  /usr/lib/libselinux.so.1
ba0eccb941cf4defa4301cca38dd6c10  /lib/libresolv.so.2
ed8fc89f90538d893374d8911c95e013  /usr/lib/liblzma.so.5
27113a703b745155a0188abd2f928a3a  /usr/lib/libgcrypt.so.20
7ea87045605168664b2715834acac696  /usr/lib/libgpg-error.so.0
c38ce1dfa8e22aa98fb1d03854292429  /usr/lib/libcap.so.2
89535abb9501b6ad7f13a624eac8a4ae  /usr/lib/libdconf.so.1
f24949b27d3b84ccc15602a70f385abf  /usr/lib/libgobject-2.0.so.0
d9bc5f211a4814961c8bd0d3468246a7  /usr/lib/libdbus-glib-1.so.2
d01a538ed7d71cadd8de595551d3a514  /usr/lib/libdbusaccess.so.1
07a53c59edcc2dc1f45147310ea4c377  /usr/lib/libssu.so.1
e488d42d3b1fc4b3f0ea2440b48ccd4d  /usr/lib/libudev.so.1
33f3a46763268b0cdc2d7cceb50b989d  /usr/lib/libmce-qt5.so.1
31fd2947b7d8adeb0f537b1ddb587bdb  /usr/lib/libgio-2.0.so.0
9860c1cb968075a048d1cbfd2b19c132  /usr/lib/libffi.so.6
73d385b50a525931daaf606a9b68891b  /usr/lib/libglibutil.so.1
baff1943bd40eaa5943c1fdc40b0202f  /usr/lib/libshadowutils.so.0
5b10ce4805ffd0396b1088d1c51e3a3f  /usr/lib/libzypp.so.1709
c6a652c1aea85c5036aead2363e4b815  /usr/lib/libQt5Xml.so.5
a774a11df53b4f733f8a8a1f70bc5d6c  /usr/lib/libgmodule-2.0.so.0
a4d5e8ea5b6b57db752d2c047dae92cd  /lib/libutil.so.1
5f8ad2ff2d5a9675c0e966b32de4bf14  /usr/lib/librpm.so.8
a3b5d440118cdcf0a6eb5addaed0c697  /usr/lib/libcurl.so.4
ea15f1a692a1f57bd2fd40c934125366  /usr/lib/libxml2.so.2
65c05364877bb3b04ca77a9017904047  /usr/lib/libsolv.so.1
1bcfdbc340621e204cab9c64a40fd894  /usr/lib/libsolvext.so.1
6645de4840de7309efd130d4ac8c3ff3  /usr/lib/libboost_thread-mt.so.1.66.0
73202e8ca72cd1723f7aa0cd27ba5c95  /usr/lib/libgpgme-pthread.so.11
f6fc3f82118663a5997ee859372bea7e  /usr/lib/libproxy.so.1
d9e7b3d0d28c7e02d3a1302241ea9f4a  /usr/lib/librpmio.so.8
04e8bdf2d42207da3ed9c9e3a731b46c  /usr/lib/libbz2.so.1
31d216058f0be807ee2ac2993077b418  /usr/lib/libelf.so.1
ebac0ee22b286cefdc74bb8cf84ede9f  /usr/lib/libpopt.so.0
c33ede7e221675f8a0c62bcf1ca8b345  /usr/lib/liblua-5.3.so
f97467a7f195328ac08287eda6671ab3  /usr/lib/libdb-4.8.so
7a4d98c2b227a856a087ed5db29285e6  /usr/lib/libnghttp2.so.14
756c912d65bf2a3708976beba79787e5  /usr/lib/libpsl.so
4ed60648b41b8cc0743e854291a1387d  /usr/lib/libssl.so.10
a7996043dd3ec389f87f67db14c40753  /usr/lib/libboost_system-mt.so.1.66.0

Just type jolla-email in terminal, not /usr/bin/jolla-email -prestart then it should run, at least on my Jolla1 device.

result is on devce-terminal:

result from the ssh-terminal:

[nemo@Sailfish ~]$ jolla-email
[D] unknown:0 - Using Wayland-EGL
[W] unknown:0 - DeclarativeEmailService::DeclarativeEmailService(QObject*) Failed to register com.jolla.email.ui service
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
[D] unknown:0 - Messaging :  opening database
Loaded xulDir:/usr/lib/xulrunner-qt5-52.9.1, appDir:/usr/bin
[nemo@Sailfish ~]$

both the same

I don’t follow.
You can calculate md5sums for corrupted files too, only if they compare equal to a known good value, the files are intact.

my guess was showing that a possible corruption is based on a filesystem-problem. in that case not all bytes of the file are readable - this would cause an IO-error.

assuming the libraries are not “prelinked” someone reading this thread could compare my md5sums to his installation … if one number is equal - we could check the others as well and maybe find a corrupted thing.

sorry for inconveniences

jolla-email is running two times in the system. (i didn’t take notice about)

 5896 ?        Ss     0:03  \_ /usr/libexec/mapplauncherd/booster-browser --systemd
21179 ?        Ssl   88:46  |   \_ /usr/bin/sailfish-browser
 2304 ?        Ssl    0:05  |   \_ /usr/bin/jolla-email -prestart
 2679 ?        S      0:00  \_ /usr/bin/invoker --type=browser -G --desktop-file=jolla-email.desktop -s /usr/bin/jolla-email -prestart

so even when closing the email-client on desktop one of these processes kept running.

so i killed both and tried what you’ve told me to do.

[nemo@Sailfish ~]$ jolla-email
[D] unknown:0 - Using Wayland-EGL
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
[D] unknown:0 - Messaging :  opening database
Loaded xulDir:/usr/lib/xulrunner-qt5-52.9.1, appDir:/usr/bin
[D] unknown:0 - Starting favorites query at 537 ms
[D] unknown:0 - Favorites queried in 627 ms
[D] unknown:0 - Starting metadata query at 653 ms
[D] unknown:0 - Starting online  query at 720 ms
[D] unknown:0 - All queried in 725 ms
[D] unknown:0 - Online queried in 732 ms
Attempting load of libEGL.so
=============== Preparing offscreen rendering context ===============
[W] unknown:0 - Drafts folder not found, saving to local storage!
[nemo@Sailfish ~]$

what a surprise :slight_smile: while email-client was started this way my claimed behaviour was not visible. turning the device back and forth had no effect on the operation . reverse check: when jolla-email was started as gnome-desktop-app - composer editor got stuck again while rotating device backwards :frowning:

when trying the same commands inside onboard devices terminal … strange things happend.

i started “jolla-email” (after checking no other jolla-email was running in the system) started composing a mail … turn device one direction … and than the other … see what happens:

hundreds of:
QML Label: Binding loop detected for property “width”

with the behaviour claimed … composer got stuck

good night :expressionless:

1 Like