Dyncal and Dynclock Icon issues with Sailfish 4

The DynCal issue is listed in the Release Notes for Koli 4.0.1 in the “Notification concerning apps from Open Repos” section. The issue also applies to the Dynclock icon which isn’t noted in the Release Notes.

Unfortunately for me I ran the update before I had seen the Release Notes. Silly me.

Both the Clock app and the Calendar app wouldn’t run after the update. I was able to remove the dynamic icons in Terminal but the apps still wouldn’t open. I un-installed the Calendar app and re-installed from the Jolla Store and now the Calendar works correctly. There was no loss of calendar entries.

I have been unable to get the Clock app working yet as there is no un-install option for it nor is it in the Jolla Store. The only option I see is to “Reset Device”. This wouldn’t be the end of the world as I can back up and restore the device data, but I’d rather not have to do this if possible.

For any of you in my situation the Calendar is easy to fix.

If anyone has a better idea other than using the "Reset Device " option for the Clock app I’d be keen to hear it.


Thanks to peterleinchen I have solved the Clock app issue.

He posted a solution in Sailfish Core Apps do not work after Update to Sailfish (sandboxing problem?)

I have copied it here.

Using terminal, type the following commands.

pkcon install --allow-reinstall jolla-clock

I should also add you will need to remove the dynamic icons before the reinstall process.
This is done by also using Terminal.

pkcon remove harbour-dyncal
pkcon remove harbour-dynclock

See my first post in this thread for the removal and reinstallation of the Calendar app.

1 Like