Downgrade to or help reset Bluetooth to defaults

I’d like to downgrade from this release (yes, I know it’s technically not supported)… It’s just a stop release, but I cannot add a specific Bluetooth device anymore on, while was able to add it with no issues… AsteroidOS 1.1 was running on the Huawei Watch and this: GitHub - atx/AsteroidOSLinux: AsteroidOS Linux control application was running on SailfishOS (installed with pip3)… I’d disconnected and removed the watch with this script running.

Bluetooth was not touched between .23 and .24, so probably it is something else acting up.

I had a Python tool for sending notifications to AsteroidOS… I had it running, then disconnected the watch with it running to reset the watch due to some issues with the pager motor not wanting to spin fully… After I’d reinstalled, that worked fine, but I was unable to pair to the watch.

Here’s the GitHub: GitHub - atx/AsteroidOSLinux: AsteroidOS Linux control application

Everything worked fine until disconnection.

I think I found the issue, it’s a bug to do with Bluez5… But I don’t se bluez5.8 (which fixes the segfaulting issue) in the repos…