Don't get blue LED prior to unlocking bootloader on Xp 10 II

I’m trying to install SFOS on a Xperia 10 II ( XQ-AU52).
I’ve followed the instructions on How to install Sailfish X on Xperia™ 10 II on Linux - Jolla down to pt. 7.8.

However, after turning off my fully charged phone and waiting for the LED to turn off (pt. 7.7), I then press the Volum up button and insert the USB cable to my pc (running on Linux Mint 20.2 C), but nothing happens - no LED light at all.

I’ve tried with another cable to the USB-C ports of the pc (which only have such ports).

What can I do to get further?
Does the phone need to have a SIM-card inserted at this stage?

Hei @espen

Is the cable a data cable or does it only supply power?
Does the device show up in Mint when it is booted in Android?

Could be you are running in to the USB3 problem, but I am really unsure if that problem extends to USB-C ports as well.
One workaround (to the USB3 problem) it to have a USB port replicator that has USB2 ports

No SIM card needed, it it just to test the device if you got a faulty from the factory (rare, but it happens.)

Thanks, emva!

Yes, it’s a data cable, and I’ve tried with various port replicators with USB2 and -3. but, since the phone doesn’t show up as a storage device when booted in Android and directly connected via a USB-C cable, I’m beginning to wonder if there is a problem with the physical connection in the phone’s USB-C port. It feels a little wobbly, and don’t lock well in inner position. (Bought this phone used – as there are no new 10 II’s left in shops – and my general experience is that the connectors are those that breaks first on the phones after some times use - at least by us who steadily are on the move.)

Or could there be anything else that prevents the phone from showing up in the pc?

Did you enable developer mode/usb-debugging on the phone?

Yes, davidrasch, I followed the procedure.

It really seems like I do have a connector problem, but by using the other USB-C port on the pc, (which also is somewhat loose, but bending in the right direction …), I was able to get the blue LED light and unlock the bootloader.

The phone doesn’t anyhow appear as a USB-storage in the pc’s file explorer, though. So the question is if I’m likely heading into serious trouble if I now continue trying to flash SFOS onto the phone?

Maybe try to clean the port with either compressed air or VERY carefully use a needle toothpick to pick out some dust.

Don’t use something made out of metal, a toothpick for example would be the better choice.

You won’t run into trouble if the phone doesn’t show up in the file manager. Cross your fingers and hope that the flashing through fastboot will work if there is a damaged port on the phone or the laptop.

After install you could use SSH to access the phone using wifi.

But if the phones port is broken you will sooner or later get charging issues…

1 Like

Yes, it worked. Up and running.