Does Anyone have Office365 Account Support Working Reliably - If so, How?

For years now I have struggled with Exchange, Now Office365, support on SFOS and it has never worked reliably or properly. There are numerous bug reports on this forum (many of them reported by me) covering:

  • O365 Mail Synchronisation failing and locking up after the network connection changes from wireless to mobile or vice versa, and which only deleting the account and re-creating it will fix things (which happens several times a day for most of us)

  • O365 email accounts freezing after a reboot, again requiring deletion and recreation of the account(s) to fix things

  • Not all O365 mail folders either being displayed or synchronised, those that are missing being at random

  • Duplicate O365 calendars being created all the time

  • O365 accounts being randomly signed out

And so on. My setups have been pretty standard (always up-to-date sync, inbox & other folders, two way sync, provisioning, etc) - although over the years I have tried pretty much every combination of option to see if it improves matters, but with no luck.

For a while I could use IMAP to access Office365 email, but now that Microsoft have removed support for basic authentication this is no longer possible with SFOS because OAuth2 is not supported for IMAP.

I’ve also tried to use Outlook for Android as well, but since mobile data connectivity for Android support regularly breaks in SFOS (there’s a bug report for this as well), this is not really an option either.

There are lots of SFOS users on this forum who have had the same problems as I have, so is Office365 support basically unusable on SFOS for everyone because of the above problems, or have others managed to find a way of getting it working reliably in some way? If so, how did you do it?

For completeness I’m on Xperia 10 III running the latest .24 release of SFOS, but have been plagued by these issues with no resolution across many previous releases.

1 Like

I can only say I have the same experience(for years) in that Exchange support is unreliable(and many stuff more, but that’s not the topic).
Sometimes it doesn’t sync (solution: restart activesync service, I use Qcommand application to execute command ‘pkill sailfish-eas’ ). Sometimes send email or calendar invitations just get lost/not send. I never use it any more for sending email. Email/calendar widgets and reminders is the best it can (kinda) reliably do.
I use Nine(Android ), and that works fine. Although I have 30 other paper cuts in Sailfish, network in Android works reliable for me.

Well, since no forum contributor has come forward to say that they’ve got Exchange/365 support working reliably I can only assume that most who have tried using it have had a similar experience to me - basically, and sadly, that it is broken and not really usable. :disappointed:

For me, it is working okay. I posted an issue with multiplying calendars, which is annoying.

Mail is fine. I can access all mail folders. Replying mail is sometimes not working as expected, I posted another issue about this.

This all is on 10iii. Earlier on 10ii, I configured two Exchange accounts. This worked until 2FA required a new browser-like login. Only one account was accessible, or so it seemed. Since then, I use one account only.

So not flawless, but workable and still worth the license fee, as I use it as daily driver, and Exchange is for work.

Sane here. I can’t get logged in either due to that browser thing on my 10 II. I assume the problem is that the world doesn’t like the SFOS browser and not the Office 365 support itself, but I guess there’s no way for me to know for sure.