Do not disturb doesn't seem to work

i thought about getting a nap, but got a loud voice call while on do not disturb.
had to put it on Plane mode.
next time I’ll try silent.
XA2 -


I can confirm that for the Xperia 10 III,

I would also confirm that it doesnt work for xperia 10 iii. Is there a patch or app we could use?

This sounds like the correct behaviour. The text for Do not disturb mode reads (at least in English): “When on, the notifications will not play sound or feedback”.

So if you activate the mode, voice calls will continue to make a sounds, but notifications won’t. If you don’t want voice calls to sound either, you probably do want Silence instead (or create an ambience that sets the Ringtone volume and use that).

I agree, the phrase “Do not disturb” might indicate that everything is made quiet. Perhaps “Silence notifications” would be better, but I’m not sure.

1 Like

I don’t agree with you. I do agree with @jub. In a hotel, you can attach a card to your door saying: don’t disturb me.
Android has much better options for setting these things. This is not about literal meanings in English, but ease of use. Customisation using Ambience is obviously not a solution to the shortcoming in SailfishOS software. It is simply a shortcoming. For inspiration, I have attached some screenshots.

In Android:
Apps & notifications
Do not disturb

Kind regards!

Thanks for sharing the screenshots. Personally I agree with you: these are all very nice features for increased control, and Sailfish would benefit from having them too.