Display blanking does not time out

REPRODUCIBILITY (% or how often): sometimes
BUILD ID = OS VERSION (Settings > About product): 4.3.0
HARDWARE (XA2, X10, X10 II, …): X, XA2
REGRESSION: (compared to previous public release: Yes, No, ?): ?


Sometimes the display blanking does not work and the display does not blank and stays lit.


Or maybe have the display sleep time less than device lock time?


  1. Display sleep after = 2 min
  2. Device lock on = 60 min
  3. use device and lay on table


Display blanks after 2 minutes.


Display stays lit.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)
Did not check it on occurence whether device lock will work.
Often browser was used and still open. But happened as well when app view (all minimized) was shown.

Device lock does not matter.


I do see this behavior very occasionally on my XA2. After restarting lipstick the blanking function is restored in my case.

1 Like

In my case(s) a simple power button or topmenu icon press and open again was enough. Then the display blanked after set time.

Sounds like this might be one of the nice and highly appreciated features: If blank timeout enters dim-stage and you touch the screen, the blank timeout gets expanded.
No idea if it is documented anywhere, but this works well and reproducable for me.
I’m playing sudoku and my 45s blank timeout (set by mce since UI unforutnately offers stepped interval settings only) kicks in when puzzling gets harder… Once touched during dim, I’m not getting nagged every 45s again, but blank timout automagically has alonger interval (around doulbed - never measured exactly). This works reliably for me and as mentioned, is a very much appreciated feature!
would be interesting if anybody would turn it off it this was an option… Helps while reading books.pdfs also…

Nope, that is definitely not the case (and have never noticed such whereas of course after touching screen the timeout starts again with preset time).
The device just lays on table (proximity not covered) and is not touched at all.

Just blank screen with backlight on? Or is there also ui visible / usable?

Any chance that there would have been youtube / other video playback going on in the browser? (Which would disable timer based display blanking)

Built-in default adaptive dimming delay list is 15, 30, 60, 120 and 600 [seconds]. When display is tapped while it is dimmed, the next larger than current delay is chosen - starting from what has been selected in Settings → Display → Sleep after X amount of time. The steps can be tweaked from command line, e.g. mcetool --set-dim-timeouts=60,120,180,240,300 → use 1, 2, 3, 4 and 5 minute delays.


Full UI with full light.

No, definitely not. Had this forum open as last used tab.
And it happened as well having browser minimized (no video) and clock app open.

Thanks, nice to know.

The same behaviour on X10II with But I’m sure it was also in the SFOS version before.

Could you provide more steps to reproduce it? I couldn’t reproduce on my X10 II

Sorry I forgot to post.
mcetool --set-dim-timeout=30
mcetool --set-blank-timeout=5
seems to solve the problem for me.
Also change settings in settings app is working now.