Determining Flatpak support on Xperia XA2?

Is anyone using Flatpak on the free Sailfish OS version? If so, do you have instructions on how to install it it? I have looked at:
and still have a question if I have flatpak support on my device.

Sony Xperia XA2
Sailfish OS Build

I entered the command lines described in the link while in Developer Mode and it returned an AUTH error.

I tried the first line again: devel-su ssu addrepo rinigus-flatpak

and the message:

[D] unknown:0 - “No carrier”

appeared and there was nothing else but the prompt on the next line.

Should work, as far as I know. Continue with the next commands

Okay. So far it seems to have worked. I tried the line: flatpak install --user appname. I would like to install “Signal” if it is available. I tried “flatpak install --user Signal”. An error message appeared:

Usage:gpg-connect-agent [options] 9-h for help)error: No remote refs found similar to ‘Signal’

then the prompt appeared. Did I type this correctly or maybe Signal is not available for Sailfish? I saw Signal on the flathub website. I’m new to Linux and Sailfish. Thanks for your help.

To my knowledge, you could mainly use Flatpak support for Angelfish and others have reported Telegram. We are restricted by Qt apps and the apps compiled for ARM32bit. I presume Signal provided only x86 flatpak.

Okay. I followed the other instructions for Telegram and it is working fine. Thanks very much for the work you put into this. I’ll stay tuned for other apps. I still need to learn what apps are available for Sailfish. Thanks.