Deployment Permission denied [solved]


I am currently trying to port my apps to 64bit. I managed to connect to my Sony 10 II via Qt Creator. When I test the connection I get an okay.
But when I try to deploy my app I geht a permission denied error:

Usage: dbus-send [--help] [--system | --session | --bus=ADDRESS | --peer=ADDRESS] [-- 
dest=NAME] [--type=TYPE] [--print-reply[=literal]] [--reply-timeout=MSEC] <destination object path> 
<message name> [contents ...]
Permission denied, please try again.
Permission denied, please try again.
defaultuser@xxxxxxxx: Permission denied (publickey,password).
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(226) [sender=3.1.3]

I am very positive that i used the correct password. The password is asked for every time I try to deploy but only once. Using SSH I can access the phone. Qt can launch a terminal as well.

What did I miss that I am not able to deploy my app?

1 Like

I wasn’t even aware one could deploy apps with password. I always deployed a ssh key as part of adding the device, or more recently used one i had deployed previously. Maybe try that?

Often when updating the SDK it has had a tendency to break the configuration of saved devices, forcing me to re-add them every time. For me that seems to have stopped now, but also something to try.

1 Like

It probably is not. I deleted the device and added it again. Now it works. Might be that I made a mistake during the first time I added the 10 II. I was not aware that the user is not nemo anymore and that might have messed up the key deployment.