Deployment as RPM package fails from the Sailfish IDE

Hello folks,

I am trying to deploy my app as an RPM package to my device by hitting the run while specifying RPM deployment:


However the installation fails with:

sent 466,416 bytes  received 35 bytes  310,967.33 bytes/sec
total size is 466,172  speedup is 1.00
Installing sailfish-ble-rc-0.1-1.armv7hl.rpm
Please confirm installation on device.
sailfish-ble-rc: nothing provides needed by sailfish-ble-rc-0.1-1.armv7hl (code: 13)
Installation failed
Deploy failed
23:03:08: The process "/opt/SailfishOS/bin/sfdk" exited with code 1.
Error while building/deploying project sailfish-ble-rc (kit: SailfishOS- (in sailfish-os-build-engine))
When executing step "RPM Deploy"
23:03:08: Elapsed time: 00:27.

My device runs Verla, but the situation was the same with the Kvarken release.
My code lives here (but I doubt that there are any hardcoded 64 bit references):

I am using an armv7hl kit, tried to remove the .config/SailfishSDK folder.
Deploying as a binary works, but I would like to get the package installed as a normal app.

I just tried building your package for armv7hl, and I didn’t get the 64bit dependency. Is it possible that you have built your project for aarch64 in the same directory, and some object file has been left there? Perhaps performing git clean -x -f -d before trying to rebuild helps?

Same here. If the hint by vige does not help, then please paste the full compile output after cleaning up both source and build directory (clone your project somewhere else to be sure).

You could also remove and re-add the build target with the SDK Maintenance Tool prior to that, so that we see whether it pulls in some strange build deps.

Yeah I forgot to mention that I used shadow builds and cleaned all of them.
I will give a shot to @martyone 's suggestion and get back with the results.

1 Like

You were right: a clean clone solved the problem.
I was surprised by this because I assumed cleaning the shadow builds should solve the problem, but it looks like I mistaken.