Depecher can't complete setup / connect to Telegram

Installed Depecher 0.7.4-1 by BlackSailer from Openrepos. Install looks good, when trying to complete setup (enter phone number and connect to Telegram server) I get the message “Connection Status: Waiting for Network” and cannot proceed. Have tried connecting both with Wlan and also LTE connection. Running Sailfish on Xperia X but also tried to setup while running Any ideas? Related to App permissions perhaps?

If you check the date of the last update released and the comments section you’d know that currently it’s no longer being maintained my friend :frowning_face:

1 Like

No longer being maintained does not equal no longer works. Depecher was working perfectly, with the above mentioned Sailfish releases until I bricked my phone and had to rebuild. If you read my question you will see I suspect the issue is with app permissions (therefore Sailfish / firejail). That’s why I posted the question on the Sailfish forum.

There’s possibly been a change to Telegram’s API, or tdlib updates that have become incompatible with Depecher, or it could absolutely be something to do with Firejail. In any case, I formerly used Depecher as well, but given it hasn’t been maintained since 2019, you’re best left to use Yottagram or Fernschreiber, both of which are in active development and work with
Yottagram was last updated in November, and Fernschreiber was updated just over a week ago. I’ve primarily used Fernschreiber since installing, but did just install Yottagram for testing sake, and was able to log in flawlessly, even receiving my login code from Fernschreiber.

While it is true that unmaintained =/= unusable, programs have dependencies, and software that’s designed to connect to a network which is constantly being updated and enhanced with features means that something that works today can absolutely stop working tomorrow. It could simply be the log-in interface has stopped working and needs to be fixed. That’s still an integral part of the application, and if it’s not working, it’s safe to assume that the program should no longer be used. You’re best to move on to a new application, or see if BlackSailer posted a GitHub or the source code, and fix it yourself. Personally, Fern and Yotta are improved in many ways over Depecher. I’d move on if I were you.

Thanks for the detailed reply, I suppose you are correct & I should move on from Depecher - since I posted I have tried Fernschreiber, Yottagram & Telegra’me. All working fine, I just preferred the integration of Depecher within Sailfish!

all i want to add: depecher still works for me on 4.0

i didn’t had to register and i do use it only for the integration usecase: share to depecher

1 Like