Defaultuser@ Permission denied (publickey,password)

The SDK just stopped connecting to my XA2. I can’t make it work no matter what. I can normally connect via ssh from the same computer using anything else, e.g. from MSYS2 shell.

ssh defaultuser@ works perfectly fine. sftp also works great. From literally ANYTHING else BUT the god damned Sailfish SDK, which out of nowhere now always shows defaultuser@ Permission denied (publickey,password).

If I switch to normal (password authentication) then I can upload new key and device test runs successfully, but if I then switch to “specific key” authentication then again there’s the same error.

Can anyone please suggest what to do?


After whole day of failed attempts to find a solution, I fixed it by brute force, i.e. by deleting - both on the phone and computer - all key files, every authorized_keys and known_hosts file I could find, restarting, and setting up everything anew.

So I don’t know what exactly caused it, but now it works again.

I´m suffering the same Problem and until now i haven´t keep it running with publickey, even when manually copy the pubkey to the device. Password-Option is missing on the QT-Editor.

I stay with the Emulator for developing.

Hey @fingus, try to do it the way eventually I did, i.e. from the device delete everything from the /home/defaultuser/.ssh folder, and then on your computer locate and delete authorized_keys and known_hosts files used by the ssh.exe command that you have configured in the SDK. Then reboot both and try to add the device to the SDK anew.

1 Like

Its working with your steps. The Assistent just ask one time for the defaultuser-/root-Password and then never again, so here is maybe the Problem.

You can Flag your Post as “Solution”!