Dead app-link in mail

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, Xperia 10…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

since i installed ‘Fernschreiber’ from the Jolla Store i’m asked whether i want to open a link in an email with either Browser or Fernschreiber. Before this installation i had to choose from Browser or Firefox.

After i uninstalled Fernschreiber mail-app is still asking if i want to open links with Fernschreiber, but not Firefox.

How can i change this behaviour and get back the choice of Browser/Firefox?



  1. install Fernschreiber
  2. open browser-link in mail-app
  3. uninstall Fernschreiber
  4. open browser-link in mail-app


mail-app asks for an installed browser-app to open like Browser/Firefox


mail-app asks for un uninstalled non-browser-app


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

check your .local/share/applications dir for stale .desktop files, remove them if necessary, and run update-desktop-database.

That should do it.

Alternatively, before uninstalling fernschreiber, disable its menu integration option in its settings.

hello nephros, thanks for your tips.

i first tried to change app-settings but unfortunately there are none.
than i removed the .desktop file in .local/share/application what removed the entry in the opening-query of mail.
than i tried to update-desktop-database but unfortunately the database update wasn’t possible.

than i thought, if i would install a local apk the desktop-database has to be updated anyway, so i tried to install signal from local source, but this installation also failed. Hadn’t problems with SFOS 3.x

I also tried to restore the App-Registry in the Settings / Service utilities with no result.

ok, i solved a part of the problem.

in ./local/share/applications there is a file named mimeinfo.cache. i deleted this file plus the Fernschreiber.desktop file and the dead link to Fernschreiber was gone.

There is only one question, how to get back the option to choose between Firefox and Browser? I already did a uninstallation plus reinstallation of Firefox, but there is no entry in .local/share/applications…

you need a .desktop file there which configures an x-scheme-handler entry for firefox, and then run update-desktop-database. That’ll recreate the mimeinfo file.

Now I don’t know how you got the firefox one in there in the first place, but there’s an app called mimer on OR which can handle this for you.