[Clock app] Scheduled alarms fail

For a couple of times now I have overslept because the alarm in the native Clock application fails to go off at the scheduled alarm time.

When I wake up later on and look the Clock application, the active alarm at 4:40 is still active and nothing seem to have happened at the scheduled time it should have alarmed. The chosen hour comes, but nothing happens.

The issue does happen on the current OS, but it did also happen in previous iterations too. Started happening “as of lately”, I wish I could be more precise.

When I intentionally try to test it on the day time, the alarm works just as intended. But then in the real world situation like today morning the issue happens. I have no idea could it depend on the phone having been inactive for hours prior the scheduled alarm, or if there is unplausibly some hidden setting of “non-active time” or somesuch.

And before you ask: no, I don’t snooze it in my sleep, I wake up as intended when the alarm on my XA2 set up as a back-up alarm goes off.

Anyone else with similar experience with the alarm clock failure on Sailfish?

The UI doesn’t support reinstalling the Clock app graphically, which I guess means that it is considered a Sailfish “core” app.

My phone is Xperia II 10 with


Can you reproduce that if you disable automatic time adjustment and set the time early?
(and if possible leave the phone inactive some hours after that)

Oh - I now realize I might have been affected by this bug in the past, too, last June. And I missed a plane because of that. :sob: I thought I overslept without hearing an unusually early alarm set at around 3:30, but it might well have been this bug.

Lol, didn’t even come to my mind that i could game the time for the system. I’ll do some trying on that, thanks.

Exactly what’s just happened to me today, just not in the “early morning hours” but at 16:00.

I had the clock alarm set at 16:00. That time has just passed without any alarm or any other reaction whatsoever, and in the Clock application the alarm remained active as if the time didn’t come yet. Between 16:00 and 16:10 absolutely nothing happened.

Then, 10 minutes later, at 16:10, a notification was SILENTLY shown on the Events screen that there is a SNOOZED alarm.

Then, yet another 10 minutes later (i.e. 20 minutes past the correct time) the (allegedly snoozed) alarm went off.

Which means that as of the Clock alarm functionality became TOTALLY UNRELIABLE. Along with Calendar alarms, which are also broken as reported here.


I tried doing this, but I can’t make the bug happen when I try. Also, the real life morning alarms I have had since this post, have functioned as they should.

It looks like the issue might be with the alarm sound, then.

It doesn’t look like just the sound, because during the first 10 minutes past the scheduled time there was nothing, not even the notification. I will further investigate it. Let’s see when it comes back.

Either way, along with some Calendar alarms also broken by 4.5.0.x update, this makes all SFOS alarms/reminders completely unreliable, and I am starting to wonder how can I continue to use this phone as my daily driver if I can never be sure not only if it wakes me up but also whether it reminds me about important events. Should I be carrying a second device for that purpose?


I can confirm. The same happens to me. Three different alarms set up at 5:45, 6:00 and 6:15, and none of them works. Neither sound nor notification.
Although it may seem a minor thing, this is a very serious issue for a basic function like this!


I confirm that this has happened to me since upgrading to

I have two alarms, each set for two week repetition (alternate alarms to put the black or the blue bin out) which fire at 19:00 the night before bin day.

Since upgrading, not only do the alarms not fire, but there is also no notification of a “missed alarm.” I have tried deleting and re-creating the two alarms, but they still don’t fire.

I’ve been holding on for the next OS update in the hope that it would have been noticed and fixed, as it’s a fairly major thing, alarms not firing. I have checked my ambience and the alarm sound is there and works… because I did wonder if it was an ambience thing since upgrading, but I’m clueless as to what could be causing it.

It happened to me too a few times since I updated my phone from SFOS 3.4 to SFOS 4.5 a few weeks ago. It’s just that I can’t reliably reproduce it, which makes it hard to write a proper bug report.

Unfortunately, I have this bug regularly with the Xperia 10/III, like every two or three days When it happens all sound seems to be lost, can’t make calls, if I call my message box, don’t hear anything either. A complete reboot seems to be required.

Definitely agree with lupastro above, this is a very serious bug . I now have to take my old Jolla “the first one” along on any business trip with me and use it as the reliable alarm clock!

This bug has been there for at least the last three updates, ever since I moved to Xperia 10/III.

Updates and fixes from Jolla are much too infrequent! Testing totally inadequate! Jolla, we suffered your lousy browser for more than five years, it seems this wasn’t fixed until the Aurora developers put in some real work and now you no longer seem to be working with them for political reasons. The bullshit self-praise on LinkedIn and the Jolla blog is just sickening!. Sailfish quality is a disaster! The only reason I still use it is because it’s not Apple/Android and Ubuntu Touch is even more useless! Maybe you should dump some of the managers and hire more engineers instead of the other way around!


like every two or three days

This means that you are using a particular workflow that enables this bug or you have a faulty device. It would be nice to have it so we can easily reproduce it.

There is this thread: [][][][] No notification sounds (ringing, SMS, alarm) and I’m pretty sure it’s the same bug as defined here. Please, continue there.

I’m not at all sure the bug is due to the user workflow or a faulty device. I would really guess it’s not, because at least for me the bug happening or not happening seems to be completely random, and I find it inplausible that we all experiencing the bug would have similarly faulty device.


I rarely have this problem on my X10-3. Surely because I do something different to you or because this machine is less affected than the XA2.

The user workflow should allow to find the differences and potentially reproduce the bug.

I also sometimes see this on my phones (X10, Volla), my impression is, it has something to do with the powersafe mode of CPU / “deep sleep” / wake up on events from “idle”. Especially if the phone is untouched for hours before, the first user actions are sooo slooow. Waking up the device by pressing power button and unlocking with fingerprint goes rather fast (only a little bit slower than usual), but then (my impression is) the system needs abt. 10-15 seconds to completely wake up and work at usual speed after it was idle for hours. This is also in the early morning if the phone should wake me up after a long night. It doesn’t always.

1 Like

The described bug is different from the one in linked thread – in that case, only notifications stop working (no sound, no vibration, phone screen not lighting up when there’s an incoming call), phone calls continue working just fine (and sound through phone speaker works). Still no idea what triggers it (I can have phone ringing, answer the call, finish it normally, and less than a minute later, the next call does not show any indication on the phone), but systemctl --user restart ngfd fixes the bug from the other thread (I set up a qCommand shortcut for it).


In my case, the way this “scheduled alarms fail” bug manifested itself had nothing to do with the “no sound” issue. It was not just the alarm sound missing but there was completely NOTHING happening - not even the alarm popup (dialog / notification) shown. Then, after the snooze period (that I have set to 10 minutes) a SILENT notification was shown on the Events screen about the SNOOZED alarm that I never snoozed. And then, another 10 minutes later (i.e. 20 minutes past the scheduled time), the alarm eventually went off with all its sounds and notifications.

So it was definitely something completely different than the famous “sudden lack of sound” bug.

(Un)fortunately, since then I haven’t seen it again, so I couldn’t further investigate it.

Interesting. I guess trying to notify could run into trouble with a dead ngfd.
My “occurrence” of this issue was just no sound at least one of the two times - i.e. there was vibration.

I tried reproducing three times now with stopping ngfd; but all three times it was brought back as if done by the alarm itself (as opposed to systemd supervision).

Indeed, dead ngfd might prevent the notification. What’s strange, however, is how it then appeared as a silent notification on the Events screen about a snoozed alarm (it happened only after 10 minutes, i.e. when the allegedly snoozed alarm should have gone off anyway), and only after yet another 10 minutes the alarm went off as it should, with both sound and dialog.

Well, it never happened again, so I had no chance to further test it.