Changing email settings not possible

HARDWARE: sony 10 II


Since some days i get an error, if i want to update the IMAP accounts. Thus i wanted to check the settings, but there are only 2 options available: “Deactivate” and “Delete”
“Change settings” is not an option in SailfishOS like in other OS?!


IMAP updating not possible any more. Maybe because the provider changed authentication to SSL/TLS without an encrypted password.



Any option the change or view the settings


still no contact to the IMAP server




Thus i wanted to check the settings, but there are only 2 options available: “Deactivate” and “Delete”

Those are the options in the context menu which shows on press-and-hold.

What happens if you just tap the account entry?

My provider (strato) removed md5 from the authentication algorithms. Fastest way was to delete and recreate the account.


I am also a Strato user. Like PeperJohnny mentioned, the fastest way to resolve the issue was to delete and recreate the account.

if you tap the account in the settings, you can change the password, nothing else. :frowning:

There is a pull down menu for all other settings.

1 Like

That’s what happend to me too.

But there should allways be an option to change settings or at least to view them.
And it’s easier to change one wrong setting instaed of deleting and creating a new account. To call this a bug is not correct, but it’s more an user unfriendly UI.


Where do i find this pull down menu?
If i open Settings > Account > “specific mail account” it offer to enter a new password,
nothing else. Maybe this is because i got an authentification error concerning this account.
If this is the reasons, why i can’t open the other settings, this is failure which should be changed.

The problem depends on the authentification.

Adding a new account starts with entering a password. Then you can add the further settings.

Thus if an account exist and the authentification fails, you can’t get to the settings. Wrong behaviour :frowning:

1 Like

I could log in one more time, but in the server settings was nothing about auth algorithms. I guess that they are negotiated at creation and that’s it. I see it your way, that it would have been if this setting could be changed some way or at least renegotiated on a new login.

Settings : Account : YourAccount → Pull down menu: Server Settings

devel-su  -p  # note the -p 
ag-tool list-accounts|grep   email
ag-tool list-settings 83 | grep imap  #  assuming 83 is the account id

Try setting the authentication setting to another integer. We know that:

  • 0 means no auth
  • 1 means AUTH LOGIN
  • 2 means AUTH PLAIN
  • 3 means CRAM-MD5

Higher numbers may mean other schemes, not too sure


For me it’s only working when I skipped the automatic mode and start direct with the manuell settings. Enter the server settings after automatic try will result in an error.

I haven’t see a selection with “plaintext password”. So the magic happened in the dark ?

You “pull down”. Maybe you should get aquainted with SFOS UI basics first? You should’ve been walked through a tutorial after installation. It’s actually still installed as an “app”.

Admittedly this helped me too in similar situations.