Car radio pairing not as a hands-free-kit

Thanks to “Mister Magister” I use my old device for many years. With SFOS3 my phone connected to my car radio with bluetooth correctly without any problems.
With SFOS4 there came connection errors and I only could use my radio as an external speaker or headphone, but not as a hands-free-kit.
With the last upgrade to I dont have any connection errors anymore, but I still cannot use my radio as a hands-free-kit. My device says that this is a car connection, but my radio not. The radio worked with my phone wiith SFOS3 correctly so I think the problem is somewhere in my phone.

HARDWARE: Motorola Moto G2 LTE “Thea”


Bluetooth conection with my car radio doesnt work as a hands-free-kit: Radio regognize my phone not as a phone - mit phone regognize my car radio as a car radio.


  1. Delete car device in my bluetooth device list
  2. Delete phone device in my car radio device list
  3. Re-pairing phone with car radio


Car radio should work as a hands-free-kit


Car radio regognize my phone only as spaker or headphone


Complete adaption of “Mister Magister” for Moto G2 “Thea”

Bug reports here are not for community ports.

“Mister Magiter” said I should report it - afaik he doesnt have a car .

I had some trouble with my 10iii which wouldn’t pair with my car radio at all after one of the 4.4.x updates. Solution was to turn off bluetooth, remove or rename the /var/lib/bluetooth folder and reboot.
Maybe this could be worth a try?

What is the car make and model and perhaps what kind of BT is it using?
My old Honda (2008) had BT v2 inside (AFAIK) and it stopped working with SFOS4 since SFOS4 shipped with bluez5 and SFOS3 with bluez4 if I am not mistaken.

What you could do, is inspect the profiles on phone and car (use bluetoothctl) and you can also try telling the phone to offer HFP

Oh, last but not least, I hope you have the SIM card in the phone working properly, because without SIM ofono is not advertising the HFP.

This is actually visible in the list of profiles (use bluetoothctl) .

Cleaning up /var/lib/bluetooth as suggested by @miau could be also an option.