Can't use WLAN on

HARDWARE: Xperia 10 Dual Sim
REGRESSION: worked without many issues on


I connect to my WIFI router, it says limited connection (bug introduced with 4.5) but discovered a fix changing the DNS manually with Cloudfire/Quad9 not Google for privacy but ok!). It works for some time, then it loses connection, and hangs forever, even after reboot device, connecting or not showing connections. So in brief, after the one time it worked it won’t anymore. And I can’t even delete connection to log in again with the password! It just says that on the screenshot and no more… So I can’t use my WIFI anymore.



  1. Connect to a WLAN Router (don’t know if the issue is VERY specific to this ZYXEL router…
  2. Use WIFI for some time.
  3. Then, OR it loses on its own working, or turning off WIFI and put ON again, it won’t connect anymore. I’ve only Mobile data


WIFI should connect succesfully after turning off and on the WIFI connection and not hang on and not doing anything…


Rolling circle and no connecting results


AppSupport, MicroG with Fakestore, Chum GUI


If you have static IP try to switch it to DHCP (automatic) . Then, if / after you connect try to set it again manual. Please let us know if it worked. With last updates network became more unstable to me.

1 Like

It seems to be fixed with proxy feature thicked on in wifi settings. However, the bug that when I turn off the Wifi and turning on doesn’t connect again is still there.

1 Like

Maybe this helps getting to the root of the issue: I noticed it when I switched off the 5 GHz channel of my Wifi, then my phone couldn’t connect anymore. So (in my case) the connectivity problem only appears with 2.4GHz Wifi. My Xperia 10 II couldn’t even find the wifi network in 2.4GHz even though other electronics (Laptop, etc) were connected to it and working.
The proxy settings mentioned above solved it, not only on first connection but also when reconnecting to it. Thanks @Valorsoguerriero97 for the workaround!

1 Like

You should check that the WLAN is not operating in channel 13 or any channel bonding mode in which channel 13 is included.


@lupastro So this appeared today and the phone didn’t connect again…autochannel had chosen 13. Thanks for the hint. It saved me another headache :slight_smile:. Luckily FritzBox has the option to avoid channel 12/13.

No problems :slight_smile: So it appears that it may depends on channel 13? My router can’t choose it unfortunately. I don’t have any issues on 4.4…
why is that?