Can't See S1Boot Fastboot

I am trying to get SailfishX installed on my Xperia 10, but I’ve got a problem in that I can’t see S1Boot Fastboot listed in the Device Manager tree…

I am working through the steps here but at step 2.4 it’s not listed. Apart from the whole process being very fragmented and complex, as long as there are well documented steps to work through I should be Ok, but I have no idea how to troubleshoot or resolve this problem.

Can anyone help?

First things first, i guess…
Have you installed the driver?
Have you rebooted since? Windows likes rebooting.
Have you successfully gotten the phone into fastboot mode (blue led)?

Edit: and if so, when you plug it in, does it show up under a different name?

Also, feel free to hop in on #sailfishos on Freenode IRC… for a communication medium that is a bit faster than the forum.

Thanks for the suggestions, but I don’t think it helps, so far I have:

Downloaded and installed EMMA.
Turned on Developer Options.
Downloaded the Fastboot driver from the Sony website.
Connected my Xperia via USB with the volume up button, I have a blue LED.
Opened Device Manager…

I can’t see S1Boot Fastboot, but I CAN see an “Android Device”, so I tried to update the driver on that but Emma tells me it can’t update the Android device.

I’m at a dead end here

I was just going to suggest you uninstall/replace whatever driver is in use for that “Android Device”, but seems you tried? (And it didn’t work?)
I don’t think Emma has anything to do with switching out what driver is in use, so i’ll suggest it all the same. To uninstall/reinstall/switch the driver through device manager, that is.

Edit: Or you mean something happened, so you tried Emma again?

I don’t think he had tried successfully installing /uninstalling the driver for “Android Device”.
I would suggest what @attah said, but maybe some extra details… If Emma hasn’t recognized your device, Uninstall the the driver for ‘Android device’ FIRST. Dont try to install/update it,as it probably would say that the driver/recent version is already installed. Restart your system after you uninstall. Now try again, I think you will eventually find the ‘S1Boot Fastboot’ there(instead of Android Device), so now you can retry installing it as per the guide.

It is important to use the very latest version of Windows. In older ones you really could not reinstall the driver, a Windows problem.

Thank you all for your help, I’ll start again from the top and let you know how it goes

Ok, Windows updates run, now on Windows 10 Home Version: 1909 OS Build: 18363.1443.

Used Device Manager to uninstall my phone, rebooted and now Device Manager shows a Portable Device “Xperia 10”, if I go to update the driver is says the best driver is already installed: MTP USB Device.

Shutdown my Xperia 10 and connect to the laptop USB with the Volume Up button pressed, get a green LED, Device Manager shows Other Devices -> Android with a warning symbol.

So have I done something wrong or is this correct? What do I do next? I have a problem with the documentation in that it seems to be sending me all over the place (Jolla, Sony, Android) but I’m not sure what the exact correct sequence of steps is as you bounce between them.

Windows may still be the problem, the current version is 20H2.

Then point 2 of the instructions says: While the device is off: Hold down the Volume Up button gently and connect your device to your computer via USB. The LED next to the speaker on the device should light up blue . If it turns green then disconnect the cable and try again.

When the LED lights up blue, simply continue “exactly” as described in point 2.

Life is never easy


This is the sorry state of proprietary software and arbitrary locks, the user needs to do some legwork.

This would imply that the phone is still on, and not in fastboot mode. Rebooting the computer with the phone still vonnected will probably take it out of fastboot mode.

As you know, that is wrong… let it settle a bit after shutting down before trying to get it into fastboot mode.

If you are just looking for a quick fix, try another computer. Linux is pretty good for this.

1 Like

Well Windows Update says I am current so I’m not sure what I can do about the version. I can get the blue LED, but when you say continue from point 2, point 2 in which document?

Don’t think I’m not grateful for people trying to help me out here, I really am, but the instructions are far from clear (to me at least) - follow a set of instructions, yup, I can do that, bounce from one set to another with no clear map tying the various bits together, is a struggle.

So, I started here:

I’m on Android 10, so need to downgrade to Android 9, so head here:

Download and install Emma from here:

Then follow Chapter 1 Option 2 here: I am assuming I do all the steps (1.2.1-1.2.7)
1.2.3 hold volume down, connect to IDB, get green LED - OK
1.2.4 run Emma - it sees the phone but says “Locked phone detected”

I go here to unlock the phone: and get the unlock code

Check if the boot loader can be unlocked following step 1 here: - yes it can be unlocked

Step 2 says I need to install the device drivers and platforms tools from here: - question, do I download the Google USB Driver or the OEM/Sony driver (from here:

If I need the OEM/Sony driver I can’t see one listed for the Xperia 10, is the Xperia 10 II the same?

1 Like

I’m not looking for a quick fix, maybe just some pointers to the right way through the maze :slightly_smiling_face:

Edit: Nvermind, you already knew what i was going to say.

But my offer still stands, hop in on IRC for a quicker discussion.

Edit2: And while this looks really sketchy, the second link “Mirror 2 (Direct)” does indeed go to google (at least at the time of writing).

1 Like

Hi, please follow the instructions of Xperia 10 here:

If the fastboot driver is missing, you would see “Android” with a warning triangle under “Other devices”. The string “S1Boot Fastboot” appears in the case of Xperia X only.

Hi, you can get the latest 20H2 version of Windows here:

This will take some time.

Thanks for all your help, but it’s just too complicated trying to work out what I need to do, in which order and which steps/set of instructions to follow. I can’t even work through the unlocking the phone steps successfully. It’s a real shame as I had a Jolla phone years ago, and quirt fancied giving it a try as a backup to my iPhone but you obviously need more knowledge (or patience/time) than I have. If there is ever a push to revisit the instructions for us less-knowledgeable users then please shout out and I would be pleased to help explain what we would need to be able to join the SailfishX club.

The link provided by Jovirkku is basically all the steps in one straight instruction page.
Only “problem” i see is that it should be made a bit clearer that any usage of Emma is between steps 7 and 8.

Edit: and indeed i did not spot that you were in the tutorial for the wrong phone either, the Sony naming is pretty messy. But starting from here lands you in the right instructions for each phone.

1 Like

I’ll take a deep breath and give it another try tomorrow - thank you for your help and patience!


  1. Unlock the phone
  2. Downgrade to Android 9
  3. Flash Sailfish X

Ok, step 1 Unlock the phone…

Unlock phone using instructions here:

  1. Check if bootloader can be unlocked

Bootloader unlock allowed: Yes (simlock unlocked)

  1. Install the device drivers and platform tools

Download the USB drivers from here:

Install driver following this:

“The best drivers for your device are already installed”

Download and extract the platform tools from here:

Developer options: USB debugging: ON

Connect to fastboot: Blue LED, Device Manager shows Other Devices -> Android with a warning yellow triangle

So this means the fast boot driver isn’t installed correctly? What do I need to check to fix this? If I open Devices and Printers I don’t see anything called “fastboot driver” just an icon called “Android” with a yellow warning triangle. There is a “fastboot.exe” in the platform-tools directory.