Can't login to Diablo Immortal

I got a Xperia 10 III and wanted to try Diablo Immortal on it. Installation from Aptoide went reasonably smoothly, but I can’t log into the game with my account. It opens a login page in the browser (the Sailfish one), and while it appears to accept my password (an incorrect password triggers an immediate error response), it then just sits there infinitely spinning the logo on the button.

I also tried installing the Android application and logging into it. It took a few attempts with a generic “something went wrong” error message until I got in. But even though the app has a “play” button for Diablo Immortal, the game apparently does not have integration and will ask for login through browser anyway.

I’m guessing there might be some issue getting the login response passed from the web page to the game. The url has “ref=blizzard-anbs://localhost:0/” at the end and searching for blizzard-anbs gives some results where players have had trouble on official platforms as well. One suggested solution is first accepting terms of service as guest, but that opens in browser as well and gets the same infinitely spinning logo. Another suggestion is to use a different browser, but I didn’t find anywhere to change which browser to use.

Any help with solving this or at least debugging it further?

Edit: I got it working. I figured that since the problem seemed to be that the Sailfish browser is unable to connect a custom URI scheme to an Android intent filter, an Android browser might do a better job. So I installed one from Aptoide. When I launched the game again, it went to character creation as guest, much to my surprise (I had expected to be directed into the browser again). I backed out of that and clicked the guest account name to switch accounts. I was prepared to copy the URL from the Sailfish browser to the Android one, but instead got a popup asking which browser I wanted to use, which was nice. This time the login succeeded, although for whatever reason the game continued to use the guest account. Going through the login process a second time fixed it and I finally had my proper account data show up in the game.

1 Like