Can't connect to emulator (from IDE and SSH)

Hi,
After a fresh install of the SDK, I can’t connect to the emulator, either to deploy an app from the IDE, or directly from the terminal with SSH.
I get this:

$ ssh -p 2223 -i ~/SailfishOS/vmshare/ssh/private_keys/sdk defaultuser@localhost
ssh: connect to host localhost port 2223: Connection refused

Device list shows the emulator:

$ ./sfdk device list
[D] SOFT ASSERT: "info.macs.count() > 1" in file ../../../../sailfish-qtcreator/src/libs/sfdk/emulator.cpp, line 472
#0 "Sailfish OS Emulator 4.2.0.21"
    emulator         autodetected  defaultuser@127.0.0.1:0
    private-key: ~/SailfishOS/vmshare/ssh/private_keys/sdk

Have you run emulator virtual machine? Device list does not mean that emulator is running.

Yes I can run the emulator and play with it fine in VirtualBox. I can also build my project and generate rpms. But deploying the rpm from the ide to the emulator gives me that error and also when SSH. I’m on Fedora 35.
I’ll try to distro hop to see if anything goes better and is related to Fedora or some config for the SDK (no issues on Windows).

Looks like your emulator vm does not have a network configured correctly. Which SDK version are you using? Could you send me your InstallationLog.txt?

1 Like

Unfortunately I already distro hopped to an Ubuntu-based one. Which is working quite fine.
During installing (on Fedora 35), I had a warning about VirtualBox (something about inet and vboxmanage), which I ignored and the installation continued. I didn’t get such warning popup on Ubuntu though.

I use Fedora 35 too, and I get the same error like you about vboxmanage when I install SDK SailfishOS. Finally, I solved it by installing VirtualBox from the repository provided by VirtualBox development instead of official fedora repository. I can connect to emulator via ssh or IDE without any problems.

3 Likes