Can't add email account (IMAP)

I have a regular email account on my XA2 with SfOS4.0.1.48 that just works fine. Now, I tried adding a new account (from but can’t seem to be able to add it – I only get the notification that the inbound connection failed. The connection would be IMAP with SSL to port 993, using email account and password.

I use the exact same settings (IMAP) on my Linux workstation with fetchmail just fine. I use a password store, so there is no typing error involved.

Is there any way to see more details for the error, as that might help troubleshooting what’s the issue?
Or am I missing something obvious?



We fixed a TLS issue with to OS release Which OS release do you have?

The summary of the bug fix:

There was a bug in our OpenSSL 1.1.1 integration that meant that some TLS 1.3 handshakes failed to resolve. This affected the SMTP server specifically. This change fixes it by allowing the ECDH parameters to be successfully negotiated for the connection.

I’m on so the bug fix should be included, I guess. Still I run into the described issue. Any way I could provide more insights?

Rebooted the other day and today setting up the account just worked ™. No idea what changed , there was no update to apps or system since I last tried. And I had tried multiple times overseveral days , so it wasn’t just a one time issue. Maybe changed something on their servers.

For me creating an account also fails on, it shows the “checking settings” for a long time and then tells me it has a time out (no specific error message, just telling me I can add the account “later”)

it’s a xa2, just flashed the sailfish X free edition, provider is using ssl with standard ports

I tried last weekend on my pinephone and there it also first failed but on second or third attempt worked

please tell me about any logs that might help or how to debug further

Could you please share the email settings (or a link to them) that you’re using (the generic ones, not your username/password of course)?

Sure and thanks for getting back to me so fast! Port 993 SSL for imap Port 465 SSL for smtp

I tried again today from a different wifi and it worked flawlessly. No idea why it failed back at home. Would it be possible for me to improve the error reporting in the UI or is that in the NDA parts?