Cant' activate location services

REPRODUCIBILITY: 98 %
OS VERSION: 4.4.0.64
HARDWARE: XA2 and 10 III
UI LANGUAGE: german
REGRESSION:

DESCRIPTION:

Location services can’t be enabled.

PRECONDITIONS:

Try to enable location settings. It’s poosible to go into that settings, make them active/enabled, but when you leave settings App or just the location settings sub page and then go back into the location setting these ar still disabled. As result the phone get’s no location data.

IO have this problem an XA2 and on 10 III…

STEPS TO REPRODUCE:

  1. Enable location settings.
  2. leave subpage or setting app.
  3. Go back to settings app-> location

EXPECTED RESULT:

After enabing location service/making the active the phone should store these settings.

ACTUAL RESULT:

Every hange made in location settings is lost wehn you leave the location setings page, leaving the cations services inactive.

MODIFICATIONS:

Android support, MicroG.

ADDITIONAL INFORMATION:

After I freshly flashed the 10 III this function worked, but is gone now. I have no idea what may cause this problems, but it’s something I had on XA2 already since SFOS 4.0. I was happy that this GPS problems where gone with 10 III, but as they show up again on this device too I don’t know what to do…

Hm, I can not reproduce this, Location turns on and off as expected from Settings also with leaving and re-entering the Settings page.

I have the strange feeling that this is caused by an Android App or MicroG (or both). 10 III worked before I installed my normal App portfolio (both SFOS and Android) and then this appeared - and I had this on XA2 too. The XA2 ist also reflashed and hasn’t this problem any more since the reflash, but runs without MicroG so far. I’ll test this now; maybe I don’t need to install MicroG to use my needed Android Apps.

I’ve microG installed on the 10iii and location works as expected. My old xa2 also run MicroG and had no problems turning on and off tge location service.

I’d also bet on an uncommon app you installed on both phones as the malfunction appeared on both.
If you can, try reflash and re-installing the apps one by one, and test the location thing in between, every time (with maybe also a reboot).

Do you have any of the location service modules/UnifiedNlp things installed/running in the microg environment?

I remember I had done that on XA2, on 10 III I didn’t.

Nevertheless this problem also exists without MicroG.
I reflashed the 10 III yesterday and tried again. Same effect. I deleted mist Android Apps, location Service stayed active, but after roundabout two hours I recognised that Location Symbol in top menu wasn’t active any longer. I looked into the System settings, location was of and couldn’t be activated.

Restarting the home screen with the Jolla Tools solved this problem, at least temporary.
And it’s definetly no ummatching Status symbol like with the bluetooth issue cause GPSinfo and HereWeGo don’t get any location then.

Some hours and tries later - and I can’t find any pattern what causes this problem. It seems just ongoing time is responsible for making the phone turn location of.

Just want to report another test of this:

I reflashed the phone. I installed all part of the System that my paid license offers, including Android support.
I installed only GPSinfo first, later some more Sailfish Apps (Piepmatz, SailPhoto, Sea Print including the calligra files, QR Clip, Pass Viewer, Tidings, Quickddit).
I enabled Jolla Account during setup, as well as eMail and Nextcloud.
Connection enabeld are 4G, WiFi, Bluetooth, NFC, location device only.

I didn’t use the phone much, just wanted to check if the problem will show up again. From time to time I checke GPSinfo and also the location settings. No loss of the location settings.

After two days I added Jolla Positioning data (all four Europe parts). Nothing changed and every thing was still working, so later I set the location setting on custom (on, on, off like recommend by Jolla). Again, nothing changed.

I charged the phone to 100 %. Same game: I wanted to know how long the battery lasts and if the problem will be back. So I just made some photos to check if they get location data (they did, except the ones I shot right after starting the phone) and also checked the location settings and GPSinfo from time to time.
Everything was still fine.

Today I installed Chum, Storeman (via the Installer from Chum), F-droid and Aurora Store as well as some more a Sailfish and Android Apps. Two hours later the problem was back.
So I uninstalled all Android Apps step by step, also the Android App Support itself, but the problem still exists.

So I deleted every Sailfish App I installed today too except Books and File Manager. I will try again now. (Chum and Storeman also still installed. )

The only thing that is sure so far is that the problem isn’t related to Sailfish OS itself and also not to the Hardware. Even Android support doesn’t seem to be responsible for that (at least as long as no android apps are used). I will check this too with XA2 where I was running into the same things an hopefully find which App causes that.

1 Like

One day later - next Status report. After every thing worked fine for several hours I installed Android support again. as well as Here we go and Aurora Store. (Side notice: Deezer and F-Droid instantly also showed up - I didn’t deinstall these before deinstalling Android support… Thought that would also be gone when deinstalling Android. )
Everything is still working fine, location is still enabled as it should be, GPS fix when starting GPSinfo in roundabout one Minute (indoors).

I’m glad that the problem can be solved without reflashing, so it must be related to an App.

So in conclusion I’ll have to find the App that causes this. (Somehow my feeling is that OSM Scout Server, Pure Maps or Telegram FOSS are responsible…)

1 Like