Cannot reflash my xa2

REPRODUCIBILITY (% or how often): when I try to reflash
BUILD ID = OS VERSION (Settings > About product): Sailfish_OS-Jolla-
HARDWARE (XA2, X10, X10 II, …): xa2
REGRESSION: (compared to previous public release: Yes, No, ?): (Don’t understand the question!)


I’ve Reset device & followed instructions for reflashing on Jolla site. I get to the
sudo bash ./
bit, I copy & paste it into terminal & hit Enter & get this:
‘bash: ./ No such file or directory’
Nothing else. Have tried two different computers (both Linux Mint(20 & 20.2). Tried two different cables and two different USB2/3 sockets on each computer.

There seems to be nobody else with my problem so any ideas for a non-tech head would be helpful.


My phone needs a reflash as internet has completely failed for my necessary android apps and now sailfish’s in-house email client is failing to send emails so the problem is getting worse!!


See problem descript ^^^


(I assume expected means the outcome that I require for a fully functional smart phone, running SFOS but the ACTUAL RESULT SECTION HEADER BELOW IS CONFUSING?)
all my in-house Sailfish apps that require it to have internet access, all android apps to have internet access for communication, updates and GPS!!



(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Sorry, not a tech head so I have no insider knowledge to add.

Did you try simply ‘./’?

or rather
sudo ./

Are you sure you are in the directory where the file exists?


Yes, the ‘working directory’ of the terminal must be this, where the prepared files are. Check with ‘pwd’ command. This is important! Otherwise the command will not find the needed files.

In earlier times I did some experiments and there I made repeatedly the experience, that the command only works in exactly the given syntax, and doesn’t work if anything is changed.


Hi, you mean this step:

‘6.5 Open Terminal in the same directory where you extracted the Sailfish OS .zip file (see step 3.2)’?

After sleeping on the problem a vague memory of doing this after a failed attempt. I’m not sure how I worked out how to do this but the instructions from Jolla would be/have been helpful as not everybody is a natural with Terminal (I’m doing this via Linux).

I’m going to see if my memory of how to do this is correct, will update either shortly if my memory is wrong or after reflashing completes (I forget how long it takes) if it is correct.

UPDATE: Reflash successful now if only Jolla could add the little bit of info about, 1) right clicking on the folder extracted from the Sailfish OS .zip folder & then, 2) selecting Terminal, all would be spot-on.


It’s because the dot in the path of the command is the directory where you are now, or your ‘working directory’. And yes, in theory you can run the command with a path to the files, from whereever you want. But its most comfortable to first enter into the directory where the files are and then use ./ .