'Cannot open empty file' - Error while downloading e-mail attachments from an Exchange account

REPRODUCIBILITY: Always
OS VERSION: 4.4.0.68
HARDWARE: Xperia 10 Plus
UI LANGUAGE: Apparently irrelevant - Tested in at least 3
REGRESSION: Most probably - I don’t remember experiencing this in previous versions

DESCRIPTION:

While trying to open any PDF attachment from an e-mail, there is a short message on the top left of the screen ‘Cannot open empty file’. I have tried it with many attachments, files are NOT corrupted and NOT empty. The file is ‘downloaded’ indeed i.e. it shows up in $HOME/Downloads/mail_attachments - but it is zero bytes in size meaning it is indeed locally empty. I have even already tried to nuke the whole directory. The E-Mail app will rightfully re-create the ‘mail_attachments’ directory, but the problem still persists.

An important note: This seems to be inded related to Exchange. I have a ‘normal’ i.e. a non-Exchange account on the same phone - Attachments load perfectly!

PRECONDITIONS:

I have setup an account with Exchange support.

STEPS TO REPRODUCE:

  1. Setup your e-mail account and make sure it works (i.e. you can send and receive e-mail)
  2. Open an e-mail
  3. Click on the attachment to try to download it.

EXPECTED RESULT:

I can see the attached file under ‘Documents’

ACTUAL RESULT:

The mentioned error comes on the screen and the attachment is NOT available for viewing/storing.

MODIFICATIONS:

None other than buying the full licence for Exchange support

ADDITIONAL INFORMATION:

I don’t know where the log is for the e-mail application. Would you mind enlightening me?