Cannot install Sony Xperia 10 iii fastboot

So, i’ve finally got my 10 mk3, started following the installation instructions but:
i cannot install de sony fastboot in my machines (i’ve tried on two different computers), once the INF is installed, i’m getting code 10, cannot initiate.

i’ve tried everything i can think about, could not fix it…
i’m on windows 10

Image of the device manager:


I’ve tried the emma program of sony, and it detects the phone when accessing with Volume down (green light).

So, i don’t think this is a problem of ports or cable.

You should use a USB2 port for fastboot.
Or tske a look in the Bios if you can disable USB3.

You mean usb 2.0???
If yes i have a problem. Both my computers have only usb 3.x ports

The later models does not seem as troubled with the USB version. So could very well still be a driver thing.

There are no sub-versions of USB2.

You’re right was my mistake so i edited.

But if the ports usb version is not the problem, what can i do?

No idea. I gave up on windows long ago.

1 Like


You could check if your bios has an option to disable USB3.0 or you could use an USB 2.0 hub.

Or this regedit script, but apply at your own risk:


For me this is totally random sometimes using fastboot with USB3.0 works and sometimes not on the 10iii.

@miau , @attah

I’ll get today a hub 2.0 (i have one but only 3.x ports) and try again.

I finally could install the drivers and install Sailfish OS!
I’m leaving the site (in Spanish) that helped me.:


Thanks for the reply and good to hear that you could install Sailfish.

1 Like