Cannot install latest WhatsApp on my SFOS phone

I’m currently having the problem that I cannot install the newest WhatsApp version(s). Unfortunately now WhatsApp wants me to update which I can’t. I tried installing with Aptoide, APKPure. I tried this with the shop apps but also located the downloaded APK files und tried to install them with the file explorer. The installation always starts and then either nothing happens at all or it says “installation failed” without giving any reason.
I’ve also tried installing via terminal with “apkd-install whatsapp.apk”. This give me this result:
method return time=1668782360… sender=:1.116 → destination=:1.1647 serial=7899 reply_serial=2 boolean true
I have no idea what that means. There’s at least no WhatsApp icon after this so I guess it doesn’t install. Any ideas on how to find what causes the problem or how to fix it?

Sailfish X on Xperia XA2, Version
I tried different WhatsApp packages from different sources

Are you running a licensed copy of SailfishOS?, if yes, do you have Android Support installed from Jolla Store?, if yes, you should download and install the latest version of Whatsapp from Whatsapp itself; واتساب

THanks for your reply. I’m running a licenced copy of Sailfish X and Android support is installed. WhatsApp also worked before it just needed an update now.
WhatsApp website only links to Google Play Store which isn’t installed. However I downloaded it from Play store with some downloader website and I had the same problems as before.

Strange, when i click the download button for Whatsapp, I get the APK download right away, no redirection to Google play store.

Sailfish Browser gives the direct download link, Firefox has the Google Play link, both obey the Android link.

Using an Android installer might help - or at least try a different file manager.

Oh thanks, I didn’t know that!

I finally got it to work. I didn’t realize that my disk space was too full. After I cleared some space it finally installed. :slight_smile:

1 Like