Can' t unlock/use PinePhone

I currently have an issue with SailfishOS on my PinePhone. After I flash it to my SD-Card and boot for the first time, I only get the language selector and the agreement-screen, after that, the phone reboots and I’ m on the lockscreen, where I can swipe down and up but not to the sides to unlock the phone.

Can anybody help me?

You need a sim card to unlock the lockscreen. See the Pine64 Wiki:

  • The homescreen may be locked unless you boot with a sim card inserted. An old expired sim will do. If you do not have a SIM card on hands, do NOT set a security code on first boot.

I have a SIM-card inserted…but it still doesn’t work

I also tried rebooting, as suggested by the PinePhone Wiki, but it changed nothing
It also shows a wrong date and time on the lock screen

Some people had this problem on the pinephone forum and found a solution: Lockscreen not moving

Issue is because a service fails on startup … seems to be fixed in 4.2, so try updating to the EA, removed ~/.jolla-startup* and reboot to see how it goes. My phone and tab are both working ok currently.

How should I update if I can’t use the system?

Yes, it is a bit of a catch 22! I can use the uart cable to get a serial console in. You would have to mount the fs on a pc, and create these 2 files
-rw-r–r-- 1 defaultu privileg 0 Sep 2 09:24 /home/defaultuser/.jolla-startupwizard-done
-rw-rw-rw- 1 defaultu privileg 0 Sep 2 09:25 /home/defaultuser/.jolla-startupwizard-usersession-done

After that, you can mostly use the system as normal…open fingerterm,
ssu re
ssu ur
zypper ref
zypper dup

providing you have ea access, and set up the phone with your account

Thank you so much for your help, I created those files and now it works!!