Can android apps save their data onto a sd card?

I would like to “persuade” android apps (threema, Here WeGo, OpenCamera) to save their data to the sd card. But I do not find a way to do this.

  • Is it possible ?
  • And if yes: what exactly must I do to achieve this?
  • I made a folder on the sd card for this: /run/media/nemo/SDCARD/Android/…
    What has to be owner:group? Is it “media_rw:media_rw” or is it “nemo:nemo” ?

Another possibility would be to map the complete folder android_storage in /home/nemo to the sd card. This I did in without problems.
But with all following versions of SFOS I never got it working.
Is this possible in
If yes, what exactly is to do?

If someone in this community could help to solve this issues I would be very happy…

Best regrads, Uwe.

Since 3.3 it is no problem IF the android app supports it. Just go to settings in Here.

Thank you very much for your help. Yes I found the setting in Here WeGo.
OpenCamera seem not to work perfectly. The settings are behaving strangely.
So there remains Threema…
Best regards, Uwe.

Threema has no control to choose a location for messages and backups. I move my backups manually to the SD card. Maybe a soft link for


to some location on your ID-Card can help. Maybe not. Make sure to backup your data before.

Thank you very much for your answer. If I understand you right, this would be something like:

cd /home/nemo/android_storage/Android/data/
ln -s /run/media/nemo/SDKARTE/Android/data/ data

and analog for tmp.
In the original locations owner:group is “media_rw 30054”. I guess I would have to set the same for the new folders on the sd card?
Best regards, Uwe.

1 Like

In the meantime I tried the symbolic link.
I think it might be a problem with the owner:group. The link shows as:

lrwxrwxrwx 1 root root 62 Oct 24 11:50 data -> /run/media/nemo/SDKARTE/Android/data/

When trying to send a picture to threema it can’t be downloaded. So the root:root might be the reason…

So it’s root:root and it is not possible the change this with the chown command.

ok, I missed the -h switch in chown. But this does’nt help either. Even with the same owner:group as the original data folder for the symolic link, it’s not working.

Yes. I am sorry. That does not work. I tried it myself by twisting the path of the Threema backup a few days ago. It was worth a try, though. :slight_smile:

I have got around 2.5 GB of Threema data in my phone’s main memory. I understand that this might become an issue. I keep all my backups -usually 2- of Sailfish, Signal and Threema on the SD card.

It’s a pity that saving pictures etc. to a sd card in Threema seems not to be possible. I also wrote to the Threema support. But the answer was evasive.
Not safe enough to use a sd card and so on…
Anyway, thanks for trying.
Best regards, Uwe.