Camera refuses to take picture on 10 III (focus hangs)

From my experience, this is because you’re moving the camera, or your subject is moving. Try to be perfectly stable, and use a fixed subject


it took me 5 whole minutes to take a picture earlier today. i have no idea what finally fixed it, or why it lasted longer than usual.

one thing i just realized- it seems to happen more often when taking pictures of LCD screens (like taking a picture of a tv)

it seems pretty likely that its a bug in the focus implementation.

EDIT: i was taking a picture of a computer monitor displaying static text in MOST of the screen, with a slow-moving screen-saver like animation bordering it. the animation needs to be out of frame completely before it will focus and take the picture.

YEP! thats it! ok, i can reproduce this now.

if you press the capture button, and then VERY VERY GENTLY shake the camera, it will never focus, and will never take the picture. when you stop, it will suddenly take the picture.

unlike the Xperia X, or the XA2, or the XZ2 Compact, on the 10 III you must be RIDICULOUSLY stable to take the picture. any motion at all, anywhere in the frame, and the camera will never focus.

i don’t mean you cant take action shots while whipping camera around like a madman. i have fairly steady hands, and the motion that delays the focus is small enough to create ZERO motion blur in the captured photos (once the initial focus happens, you can move the phone again and snap a few pictures)

edited the bug report to reflect the actual issue. thanks again mousse04!


I had this today whilst in Norway trying to take a picture of a pretty spectacular waterfall at the end of the Briksdal glacier. The camera couldn’t focus because of the moving water and there seemed to be no way to turn the auto focus off. No matter how many times I pressed the shutter button the photo wouldn’t take. It surely can’t be meant to work like this.


yea, its 100% a bug, and a regression (either between 4.3 and 4.4, or 10III).
jolla needs to get on actually implementing a good camera API with camera2…

Yes, this happens with my Xperia 10 III with

And yes, it’s a bit annoying, but on the other hand i’m sure it will be fixed sooner or later. So i’m patient.

And otherwise i’m pretty satisfied, because i have to admit, Sailfish is a pretty great operating system, and 10 III is a pretty awesome phone.

1 Like

yea, SFOS is great, but this thread is neither an endorsement of SFOS or a condemnation. its just a bug report, for a very serious bug.

also, any particular reason you are confident it will be fixed? is there a team working on camera improvements at jolla or something? from their announcements, it seems to me that they consider camera functionality a low priority, and leave it to the community to make it usable.

quick note about my workaround: if you use advanced-camera, you can set it to manual, and then (for example) point the camera at a rock the same distance away, tap to focus, and then move the camera back to the waterfall and snap it without re-focusing

however, if you tap-to-focus on the waterfall, even in manual mode, it will hang forever. i find that, in practice, i accidentally tap-to-focus all the time. im thinking of re-compiling piggz app to require double-tapping or long tapping to focus when in manual mode as a better workaround.

i cannot WAIT for true manual focus (which i hope will be part of any camera2 api SFOS impl). something ive always wanted in my phone but never had…

1 Like

heh, it is EXTREMELY EASY to change advanced-camera to do long-press instead of click to focus. edit /usr/share/harbour-advanced-camera/qml/pages/CameraUI.qml as follows:

--- CameraUI.qml
+++ /usr/share/harbour-advanced-camera/qml/pages/CameraUI.qml
@@ -583,7 +583,7 @@
         id: mouseFocusArea
         anchors.fill: parent
         z: -1 //Send to back
-        onClicked: {
+        onPressAndHold: {
             if (settingsOverlay.panelOpen) {

N900 had that, loong time ago…
Ok, ok, I am sorry biggrin

1 Like

HAHAHAHAHAHAH where do you think i learned to want it? my n900 was the last time i actively liked a phone.

Just take a break and chill out, man. All i’m trying is to be nice. Something positive to counterbalance the negative. And why wouldn’t it be fixed, my friend?

1 Like

Maybe for the same reason as other bugs not fixed for years? Like e.g. this one, two years and counting:

i was asking, with hopeful sincerity, if you knew of some particular reason it would be fixed.
because, afaict, they don’t fix camera bugs, ever. Xperia X still has a broken focus model, and they just abandoned it and moved on. not to be too snarky, but its not far fetched to guess that in 6 months, SFOS will only really work well on Xperia 11 Mark IV or whatever.

that being said, i was also extremely pessimistic about VoLTE ever being done, but jolla got it done a full month before my 3G got shut down, and it works GREAT. :smiley:

Thanks for your bug report @teleshoes. I’ve created an internal report about it and tagged this as “tracked”. It’s possible that this is related to the Camera API 2 which has been discussed elsewhere, but either way it seems to be a valid issue. If I find out more about it, or if there are updates to share, I’ll do my best to post it here.


I’m quite sure it’s related to the Camera API: With Open Camera (an android app) you can select which API to use. With “Original camera API” the behaviour is similar to our camera app. With “Camera2 API” it behaves a lot better, i.e. it takes pictures even while moving the phone.


I think I started seeing this on X10II on my «add swap to relieve memory pressure» adventure.

When things become real swappy and laggy, chances of this bug triggering in Camera becomes exponentially higher.

More diagnosis of the problem here. Not so much a bug but unimplemented Sony autofocus (and colour correction) features.

1 Like

no. this is very much a bug, just not a SFOS bug.

it IS a vital defect on SFOS 10III, and not on android, however, since there is no native camera2 app AND jolla-camera implements only auto-focus.

jolla-camera could workaround this very serious bug by implementing a focus model similar to AdvancedCamera, which works much much better.

OR, as is already being worked on, develop camera2 api.