Camera app keeps self-launching on Xperia X Rokua

REPRODUCIBILITY (% or how often):
100% on my Xperia X (haven’t tried reinstalling, but behavior persists across a number of reboots)
BUILD ID: Sailfish X Free 3.3.0 Rokua
HARDWARE: Xperia X
UI LANGUAGE: German
REGRESSION:
fresh install

DESCRIPTION:

Camera keeps launching itself into foreground every 10 seconds or so

============

PRECONDITIONS:

Fresh install of Sailfish X Free Rokua on Xperia X

STEPS TO REPRODUCE:

  1. Install Sailfish X Free on Xperia X
  2. Boot up the phone an start setup procedures (I completed tutorial first)
  3. Camera app launches itself. If I put it into background, it comes to the foreground again by itself. If I close it, it launches itself again.

I think there is a camera-launch gesture somewhere in settings. Does it change anything if you disable / enable that?

Maybe there is a problem with the camera-button on the side of the phone.

3 Likes

I enabled the camera-launch gesture (“quick camera access”), which seems to make the auto-launch somewhat less frequent, but still it does keep happening.
I tried this after resetting the OS to factory status in Settings > Info, but no luck.
I wonder if there’s any way to uninstall or completely disable the camera app?
Else, how would I go about diagnosing why this is happening?

I got the impression the phone heats up and that’s when the random launching happens. I’ve seen this on this very phone under Android as well as on my Blackberry Classic, but they would do all kinds of random things, launch several different apps etc when hot.
However, I can’t really see what would make the phone overheat here, as I’m not doing very CPU-intensive things, and besides it really just should’t do that.

I tried playing around a bit with the hardware camera button. Nothing happens when I press or half-press the hardware cam button, when I long-press it, the camera app is launched.

[quote=“bennypr0fane, post:4, topic:1129”]
I’ve seen this on this very phone under Android as well[/quote]

That indeed sounds like a hardware issue.

You could try launching the csd app, go to Individual Tests -> Key and see if there is a test for the camera button. (Edit: there isn’t.)

It’s not like that happened all the time. Only rarely, on some of the very hot days last summer. I just mentioned it because that’s what this randomly-auto-launching-things-behavior was reminding me of. Nothing of the kind has been happening for months now though before I flashed SailfishOS. I believe something super CPU-intensive must be going on there.
I don’t think there’s anything wrong with the camera button.

I’ve got the same issue. One thought is, that my phone get hacked and the attacker is using the camera or mic - sounds paranoid. :smiley:
I don’t think, that it is a hardware issue, because it happens randomly. There is no link to environmental situation: it happens in my pocket, on my desk without touching it, on hot as well as cold days… The phone heats up and also consume battery if the app is running.
I found out, that before it starts, the flash light blinks shortly or the display is turning on for less then a second. That’s a strange behavior.

EDIT: I dont’t have the described restart of the app after 10s. It opens randomly (after 10min or after 2h). After a restart and not opening any apps, it don’t happen. I’m using a lot of android apps, so i can’t distinguish if it belongs to the emulator / android apps.