Camera and Gallery app sailjail permissions since Koli 4.0.1

I used to have /home/nemo/Pictures/Camera symlinked to my sdcard, which is bigger and encrypted compared to internal storage on my Xperia X like this:

$ ls -l /home/nemo/Pictures/Camera
lrwxrwxrwx    1 nemo     nemo            38 Jan  4  2020 /home/nemo/Pictures/Camera -> /run/media/nemo/sdfish/Pictures/Camera

But since Koli 4.0.1 and sandboxing, this no longer works well:

  • Camera app can still save photos in the Camera directory just fine
  • Gallery app doesn’t show any photos stored there
  • but if I open jpeg file with the photo via File Browser, Gallery app shows it just fine

How could I tweak permissions to make Gallery app to show files from the camera dir the photo gallery again?

Why are you symlinking? There’s been an option in the Camera settings to save to the SD card for some time now, so you can just remove the symlink and go to Settings -> Apps -> Camera to tell the camera to save directly to your SD card.

Gallery just shows what tracker tells it to show, so the problem is most likely that tracker stopped indexing your symlinked pictures, but if you just get rid of the symlink setup, tracker should start indexing /run/media/nemo/sdfish/Pictures/Camera again.

I recall that before creating the symlink, I tried to just configure Camera app as you said, but Galery stopped showing the photos, so I tried the symlink and it seemed to work until upgrade to 4.0.1.

But you have a good point: now I just tried to remove the symlink setup for photos and reconfigure Camera app to use sd card, and at first it had no effect on the Gallery again. But when I rebooted, it started to work as expected. So most likely I had no reason to use the symlink approach in the first place. Maybe I just needed to reboot or restart tracker.

Anyway, thanks for the suggestion.