Call with VoLTE hangs up if recipient is not available

REPRODUCIBILITY: 100% (always)
HARDWARE: Sony Xperia 10 II - Dual SIM - xqau52 - xqau52 - - aarch64
UI LANGUAGE: Deutsch (user: de_DE, os: de_DE.utf8)
REGRESSION: yes (since: - aarch64)


The calls (and mobile data) crash on my 10Ii since frequently when calling with volte. (telefonica/alditalk)


Telefonica germany, alditalk


  • Bluetooth headset connected, working fine
  • I call someone
  • No ringtone
  • Message, telling me that recipient is not available starts playing via phone speaker for 1 second
  • Call hangs up
  • Mobile connection crashes, no network at all
  • Reconnects


Headset is used, call does not crash


Call crashed, sound is played via speaker


  • Patchmanager: no
  • OpenRepos: yes
  • Chum: yes
  • Other: no:


Device Owner User: defaultuser
Home Encryption: enabled

the initial version of this bug report was created using Bugger 0.9.8+git1

@flypig i got logs, as I understandit they may contain private data. How do we handle them? Can i annonymize them ( they contain hex data dumps), or upload them where they are not publicly available?

I think those are the relevant lines, they should be save to share:

Okt 19 20:50:26 Xperia10II-DualSIM ofonod[28166]: Facility lock query error: INVALID_ARGUMENTS
Okt 19 20:50:26 Xperia10II-DualSIM ofonod[28166]: Requested file structure differs from SIM: 6fb7
Okt 19 20:50:31 Xperia10II-DualSIM ofonod[28166]: Facility lock query error: INVALID_ARGUMENTS
Okt 19 20:50:31 Xperia10II-DualSIM ofonod[28166]: Registered interface org.ofono.NetworkTime, path /ril_0
Okt 19 20:50:31 Xperia10II-DualSIM ofonod[28166]: nw selection is already auto
Okt 19 20:50:32 Xperia10II-DualSIM ofonod[28166]: Requested file structure differs from SIM: 6fb7
Okt 19 20:50:35 Xperia10II-DualSIM ofonod[28166]: export_entries_one_storage_cb with ME failed
Okt 19 20:50:49 Xperia10II-DualSIM systemd-journald[625]: Suppressed 151 messages from ofono.service

they appear immediatley after the call hangs up and the network crashes

Thanks for the report @thigg, and for providing the abridged logs. And sorry for not replying to your earlier message about it.

I’ve created an internal bug report and added your logs to it. I’ve also tagged this as tracked. If there are updates on this in future I’ll do my best to post them here.

@thigg: we discussed this internally and @slava looking looked through your logs. Unfortunately we’re not able to reproduce it. From what you say in the bug report you can reproduce this reliably; would you mind please collecting some more logs for us during the period in which the crash occurs?

The following will output details from your historical log containing relevant keywords, so would be something to run directly after a crash to pick up any details:

journalctl -b | grep -iE '(ofono|voicecall|telepathy)'

Alternatively, if you run this and then trigger a crash, it will follow the logs and generate output as you go along:

journalctl -f | grep -iE '(ofono|voicecall|telepathy)'

If you could collect some output from one of these and share the logs with us (again, ensuring first that there’s no sensitive data in there), then it would be really appreciated and hopefully helpful.

I sent you the logs. I tried to reproduce it today with another friend and everything worked normally. However I can reproduce this with friends that are using AldiTalk/Telefonica.

If you need more i saved the whole journal, that should contain everything

Thanks for sending me the logs @thigg. Hopefully what you provided will be enough to diagnose the issue, but if not, I’ll get back to you to request the full set of logs. Thanks for going to this trouble.

Still happens with 4.5. (Can not edit first post anymore)