Call Recorder app no longer works after OS update

Ever since updating to 4.4.0.58 Vanha Rauma this app doesnt open. I found it using the Storeman app incase anyone was wondering.

After reading the comments for the app in storeman, i found this comment but dont know how to apply the fix:

Disable sailjail in /usr/share/applications/harbour-callrecorder.desktop

if anyone can help me get this app working I would GREATLY appreciate it! I know how to use the built in call recording feature in sailfish, but its not ideal (plus i cant figure out where the recorded call files are actually kept)

Thanks!!!

-Mark

1 Like

I cant believe it, but i actually figured it out myself.

i used a text editing app tinyedit to edit the file harbour-callrecorder.desktop (located in /usr/share/applications) and added to the end of the file:

[X-Sailjail]
Sandboxing=Disabled

then saved it to my Documents folder. Then i downloaded ToeTerm and used the command devel-su to run as root, then I used the command: cp harbour-callrecorder.desktop /usr/share/applications

It replaced the file, and now it works great! Hopefully this helps someone else out here.

4 Likes

I have recently accidentally record one call with original OS function and it worked great. No changes needed.

I’m glad you fixed it yourself.

1 Like

Could you please tell me what device do you have?
I have a Xperia 10 II and I can’t use call recorder, because mic stops working after recording an outgoing call:

I have an xperia 10 plus, and sometimes ot doesnt record both sides of the phone call also, but it seems random whenever it wants to work properly or not. Also, I LOVE my sailfish phone, the price of the phone and price of Sailfish X was worth every penny! In the future if I have a problem with an app, I will try the same fix

edit: does anyone know where the recorded call files are kept when using the built in call recording feature? I know how to display and play the recorded calls, but cant seem to find the files themselves

The recorded call files are in ~/.local/share/system/privileged/Phone/CallRecordings

2 Likes