Bugs after re-flash Xperia 10 II dualsim

REPRODUCIBILITY: re-flash Xperia X10 II dual sim following instructions from Jolla.
OS VERSION: latest
HARDWARE: Sony Xperia 10 II dual sim


Can’t download from jolla store, always keeps in waiting when you try to download an app.
The browser becomes unusable after doing pinch and zoom from any website.


I decided to re-flash the Xperia 10 II dual sim with latest update available. After doing this, this problem keeps doing.
Can’t install any app. Even from the terminal, doing a pkcon refresh … keeps in 0% progress bar…


  1. flash the device
  2. configure
  3. install apps


Error on jolla store and software update. Pkcon does not work, browser is unusable…


Can’t install apps and unable to use the browser.



Sounds like you have a problem with your Jolla account or your internet connection.

my account is in perfect condition, the internet connection too.

Once after an update I had the same problem. Solution was to delete the Jolla account on the phone and create a new one and enter the cred’s new, after this it worked perfectly again. Worth a try…?

Thank you, and what about the license bought under the present jolla account?

I did it, but keeps in mode of waiting

A really annoying solution may be to revert it back to Android and reflash it again to Sailfish.

To confirm, to reflash sailfish, you followed instructions here: Reinstalling Sailfish OS | Sailfish OS Documentation

Or simply flash again, maybe something went wrong while flashing this time.

I did it 3 times the proces of flashing. With different cables, ports, … the flashing proces always says that went ok.

I did it. Next move will be reinstall android, update and then flash again…

Just to be clear, you did what @Seven.of.nine suggested and simply created a new account, instead of logging into your one, to see if that allowed you to download apps?

yes i did. i’ve tried all the suggestions in this forum and more…

According to #sailfishos IRC channel, there is some kind of issue with the servers. It is known already and being worked on.

We’ll just have to wait, I’m afraid.

1 Like

thank you. also i’ve noticed that i cant do an ssh from my computer.

@nephros confirmed a ‘server down’ for at least yesterday in another thread. Sorry, i can’t link to this post at the moment because the ‘link’ button on nephros’s post does not work for me at the moment, too.

1 Like

I meant to create the account’s entry on the phone new, in ‘Settings/Accounts’, (not on the Jolla server). And I forgot to write, reboot the phone before creating it new on the phone using the old existing credentials of the old existing account linked with the paid licence.

1 Like

Hmmm. I noticed that all my webviews from installs on the weekend no longer behave normally. two fresh installs GS5 / Volla 22 and GS290. Are you getting proper ‘mobile’ rendering on webviews, something like Tidings with a built in webview?

I’m a bit perplexed. It seems the repos are up again but something is odd.

how many of the users that are affected did try the sailgapps script, that allow google play services on sailfishos ?

I didn’t even know that sailgapps exists, so i didn’t make any experiences. I decided for SFOS years ago because it’s more or less Google free…

So I’m also not very happy about the fact, that nearly every user interaction in this forum (even scrolling up and down) causes server interaction and network traffic.

This sometimes makes the user experience very slooow when server capacity or network connection is on its limits.

So many malfunctions of server and forum could maybe have the simple reason, that maintainance is done at server side at a moment. I sometimes made the experience that malfunctions occur, and if I do nothing and try again one day later, everything worked fine again.