[BUG] [X10III] NewPipe crashes when or after closing a video

REPRODUCIBILITY: At least 90 percent
OS VERSION: Vanha Rauma
HARDWARE: Sony Xperia 10 III
REGRESSION: This problem didn’t exist 6 months ago, but it occurred before updating to Vanha Rauma.


There are two types of problems:

Type 1: NewPipe can’t survive closing a video without crashing.
Type 2: NewPipe can’t survive closing a video and performing another task (opening the menu, pressing the ‘return’ arrow, opening a new video) without crashing.


  1. Have access to Android App Support
  2. Install NewPipe from F-Droid


  1. Close all the apps or reboot the phone
  2. Launch NewPipe
  3. Open a video and let it run for a while (e.g. 1 minute)
  4. Close the video (sometimes this is enough for the crash to occur)
  5. Open another video / press the ‘return’ arrow / open the menu


I exptected one of these two types of outcomes:

  1. Closing the current video without crashing.
  2. Closing the current video and performing another task after that.


NewPipe crashes, sometimes the whole Android Support layer crashes too.



Another post that may be related:

I have collected logs from the Sailfish side using this guide. Since they may contain some sensitive information, I will not share them in this forum, but I can send them to Jolla personnel.

When trying to collect logs from Android side using the command

lxc-attach -n aliendalvik -- /system/bin/logcat > $MYHOME/android-logs.txt

I run into following error

lxc-attach: aliendalvik: terminal.c: lxc_terminal_create_native: 927 Not a directory - Failed to open terminal multiplexer device

and no file android-logs.txt is created.

I’ve tried to use NewPipe Legacy instead, but the problem persists. Also, new clean install of NewPipe had no effect.

Me and my friend tried to reproduce the same behaviour on his phone (X10III & Vanha Rauma), but weren’t able to do that. If you can help by trying to reproduce this on your device, I would be very grateful!

1 Like

i has NewPipe 0.23.3, and it works perfect.
Thank for your reporting, i’ll wait with NewPipe updates i think.

I have the same problem in an XA2 PLUS, it closes all the time and causes android apps support to restart, I have version 0.24.1

looks like need bug report to NewPine too…

Just a small update: I read through the log file and couldn’t find anything sensitive, so here it is.

Good thing you brought up the software version, I have tested both 0.24.0 and 0.24.1 with similar results.

I couldn’t find a similar bug reported on their GitHub page, @sashikknox. Are you sure the problem isn’t related to SF or Android App Support? Sorry, if I misunderstood you there.

yes, its SFOS Android support problem, but in same time its some NewPipe problem ( maybe it can be reproduced on some clean AOSP devices )
But i think, you should try describe your problem in NewPipe bug tracker.

1 Like

Did you make sure the app is not killed by the system because of memory usage?

debug wiki

1 Like

That’s a good question @thigg. I didn’t check that before writing the report. I have no idea what is the best way to check that, but I tried command

devel-su dmesg -w | egrep "lowmemorykiller|oom_reaper|^ {19}.*|Out of memory"

after which I launched NewPipe, opened a video and closed it which led to a crash. This is the output:

[87531.721087] init: Command 'chown root system /sys/module/lowmemorykiller/parameters/adj' action=boot (/init.rc:670) took 0ms and failed: lchown() failed: Read-only file system
[87531.721176] init: Command 'chmod 0664 /sys/module/lowmemorykiller/parameters/adj' action=boot (/init.rc:671) took 0ms and failed: fchmodat() failed: Read-only file system
[87531.721250] init: Command 'chown root system /sys/module/lowmemorykiller/parameters/minfree' action=boot (/init.rc:672) took 0ms and failed: lchown() failed: Read-only file system
[87531.721317] init: Command 'chmod 0664 /sys/module/lowmemorykiller/parameters/minfree' action=boot (/init.rc:673) took 0ms and failed: fchmodat() failed: Read-only file system
1 Like

This problem was solved by updating to Struven ketju. I’m happy I got rid of the biggest annoyance I’ve had with the system so far. Great work!

I’m not sure if I’m only imagining this, but my first impression is the whole Android layer is working somewhat faster after the update.

NewPipe stutters heavily on my 10 III and Struven did not make any difference.

@Kea, do you mean NewPipe is still crashing as I described in my original post? Maybe you could try to collect logs as I did a couple of posts back. I would be curious to know, if the logs are identical. I tried switching between wlan and mobile data, but in my case there was no difference; NewPipe is running flawlessly.

In case your problem is similar than mine was, I will uncheck the “solution” post.

I guess it is not the same problem as yours. Yet I want to mention it here and not in a separate subject. NewPipe is unusable because of the stuttering. This happens on the 10 III only, not on my XA2+ (both updated to Struven).
Microtube works better now.

As the original bug is resolved and this topic is about to be closed, I highly recommend opening a separate bug report for your issue. The recommended way to do this is the bugger app.

(Edit: I just noticed, this is not in the bug report section, so never mind, would still recommend this.)

I’m sorry for taking this long before answering.

I would encourage you to create a separate report, because the underlying cause of your problems might cause other problems in the system as well. Since this topic is marked as “solved”, it doesn’t really invite any new posts or digging into the problem.

Because it is a third-party Android application, I didn’t feel good about posting this into the bug report section. However, it still is a bug report and should be treated as one. So, I second your opinion about opening a separate topic for the other issue.

On my 10 III with NewPipe videos only work for about 20 seconds, that it stops. Can’t open it again. uTube does not work either.
It must be a Sailfish or a Sony thing, for on my husband’s old GS290 with /e/ (wifi only) NewPipe works fine.

Do you have latest NewPipe version (from F-Droid for example). Usually when I have this kind of problems I do the update and it works again flawlessly until a new update is coming.

Same phone and NewPipe 0.2.5 here. I rarely have these issues.

Same phone, same OS version and NewPipe version and haven’t had any real issues since I originally solved this topic.

Does the android app support crash when NewPipe crashes? I wonder what might be the cause for the differencies in the functionality of the app. I would still encourage you to open a separate topic, since it seems like we are talking about a different problem here. It would be interesting to find out what causes the crashes in your case.

Hi Kea
When I first had the issue, which seems to be generally solved, I found a workaround that would always work:

  1. disable auto -play in the settings
  2. Always download the video, never play it Online in newpipe
  3. Play the video from the ‘Downloads’

Best regards,

Thank you, I will try that.