Bug Sailfish SDK armv7hl Arch Hash Error

This has to be an issue on Jolla’s side there is no other explanation:

  • Ubuntu 20.04 LTS
  • Latest SDK (offline or online doesn’t matter)
  • Latest virtualbox

Run the SDK, select armv7hl as one of the architectures (for me it was the only one). You will get repeated “Hash error this is temporary please try again later” after the tool is installed, at around 17% completion.

I have been trying for about a week now.

For funzies I tried with zero issues.


indeed there is an issue: Somehow the file has been truncated on the server. Looking at the timestamp it seems this has happened when we published SDK 3.7 to all users. Thanks for the reports, we will fix this asap.

P.S. I’ll mote this post to the more appropriate “Bug Reports” category.

Awesome. I kept thinking I had screwed something up but couldn’t see how!

I appreciate you moving this and working on the issue.

Now the package has been re-uploaded to the server. Please note that it might still take a while before the change has propagated to all caches, so if you still get the error, try again after a while.

Thank you.

Extra characters to meet 20 characters.