Bug Report ‒ Forum User Info broken → Unable to send PM to affected users

While communicating with user

olf

It became clear that I wasn’t able to PM (no button visible) or otherwise see the usual meta data. I saw:

[missing {{voteCount}} value] Upvotes

This user’s public profile is hidden.

Investigating with Olf and it seems;
a) the profile is not hidden
b) the PM functionality is all there.

This is stil the case. I have not encountered another user where this is the case.

Anyone any ideas?

3 Likes

Thanks to @poetaster for this bug report.

I might add, that I checked my user settings a couple of times, after we successfully established private messaging at this forum (it just took me to start the conversation): In search for any setting which may have caused this, I found nothing relevant.
I just do not display my email address (“Email: Never shown to the public.”, which likely is a setting many choose) and have no “Name: your full name (optional)” set, which is explicitly marked as optional. And in the section “Notifications: Users” I left every setting at its default.
For some more details, see Migrating Sailfish OS git repos to Github - #54 by olf

@nthn is (just) another example…
You may also count @rozgwi into this club
(did someone @jolla notice?)

And continuing the list here as wiki :wink:
@olf
@nthn
@rozgwi
@Bellini
@jenix

1 Like

That’s strange, I checked my settings and I can’t see anything out of the ordinary. The setting “Allow other users to send me personal messages” is enabled, too.

@nthn
Did you receive my ‘private’ message?

Ditto for me.
I already checked that multiple times (including toggling this setting back and forth) when @poetaster reported to have issues contacting me per PM.

=> This is most likely a bug of the forum software.

I did, yes!

@olf: I do recall setting something to ‘private’ when I signed up. Perhaps there used to be a setting we both switched on (or off) which is no longer accessible, but is still in effect.

Maybe, maybe not.
I do not remember and do not care, because I am pretty sure not to have done anything extraordinary.

We have done quite some research, provided all information available to us, thus now it is Jolla’s task to fix their forum.
Or not, sticking to their tradition, which is to run the same broken version for many years (e.g., Askbot@TJC) and then switch to a completely different software. I guess, “Don’t move and break things” is the motto. :wink:

1 Like

@vige ?

At least I know how to contact you other way, @olf! :wink:
And there is also a workaround to PM one of those affected guys.

@peterleinchen thanks for the heads up. did you try to send me a PM, too?

No, as it is not possible to contact you privately.

Just checked my settings, everything seems to be correct (messages enabled, no user on my ignore list).
I also send you a test message @peterleinchen, maybe it works the other way around?

Yes, of course.
As my profile is not affected.

But no one can contact you directly.
It is only possible after you contacted that one.

In the Preferences there’s a section called ‘Interface’ (accessible from the drop-down that also has account, profile, etc).
Down the list under the heading Other I found a little checkbox labeled:

 Hide my public profile and presence features

does any of the affected have that enabled ?

edit: I unchecked the box.

Just verified this with @peterleinchen. This little setting is the cause

1 Like

I do not concur with “This little setting is the cause”, because enabling it should not make one un-addressable for private forum messages.
While it is good to know that switching this setting off lets the bug disappear, as a workaround, the bug is still a bug, which Jolla should file upstream (at Discourse; maybe it is already there or even fixed).

Now I finally understand what these complaints are about, at least I think so. And my understanding is that this bug report is invalid. It’s still quite possible to send private messages to users who have selected “that little setting”. Here’s how:

On the front page, select “New topic” from top top right corner. Next to the “Create a new Topic” text, on the top left of the message box, there is a button with a plus sign. Click it, select “New message”. Write the recipient user name to the “Add user” field, write message, profit!

Now the fact that there is no “Message” button on the user info box could be considered a bug, but as that is not the only way to send messages I’m not sure how serious bug that is.

You can use a (complicated!) workaround, but that doesn’t really make the report invalid.

2 Likes

It is not only complicated but completely not obvious. I am pretty sure 0.0x% of all users would know this!
I -for sure- would have never found this!

My workaround was to ‘report/flag’ a post of such user and choose ‘I want to talk to this person directly’. I do hope that this does not lower his ‘karma’?

1 Like

That should also work. It shouldn’t lower their ‘karma’, as you are not really flagging the post but just sending a message.