Bug in email account setup

REPRODUCIBILITY (% or how often): 100 %
BUILD ID:
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: german
REGRESSION: (compared to previous public release: Yes, No, ?): had been the same on Rokua before.

DESCRIPTION:

When setting up a new email account the input in the fields
*description
*your name
*signature

is not saved. Also sync interval doesn’t offer “always actual”.

You need to go into the account again, then the inputs, are saved, also selecting sync “always actual” is possible then.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. setup new email account
  2. fill connection data (email, user password, server). Iif connection data is correct the second page shows up. Use IMAP/SMTP and SSL for both.
  3. Change text fields description, your name and signature.
  4. select sync interval - always actual not shown, go back.
  5. finish account set up.
  6. in account list the description of the new email account is generic email instead of the given description.
  7. tap the account to go to settings.
  8. description, your name and signature have still default value.
  9. change that values again.
  10. tap sync interval - now always actual is shown, select this.
  11. Save changes - this time the values are saved.

EXPECTED RESULT:

The values given to that three fields should be saved during the initial setup of that account.

Sync interval should offer “always actual” in initial account setup (but maybe that’s impossible as long the setup isn’t finished, maybe Imap idle needs a server response first to get detected).

ACTUAL RESULT:

As described under reproduce steps.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Thanks for reporting.
There is definitely something wrong here. An internal bug is filed.

1 Like