[bt] a2dp_sink is not available for Galaxy Buds2 Pro

x10mk3, latest version.
it was working a month ago.
any suggestions?

$ pactl ls
2 card(s) available.
    index: 2
	name: <bluez_card.98_0D_6F_07_XX_XX>
	driver: <module-bluez5-device.c>
	owner module: 23
		device.description = "Galaxy Buds2 Pro"
		device.string = "98:0D:6F:07:XX:XX"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_98_0D_6F_07_XX_XX"
		bluez.class = "0x244404"
		bluez.alias = "Galaxy Buds2 Pro"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
		a2dp_sink: Воспроизведение высокого качества (приёмник A2DP) (priority 40, available: no)
		headset_head_unit: Гарнитура (HSP/HFP) (priority 30, available: unknown)
		off: Выключено (priority 0, available: yes)
	active profile: <off>
		headset-output: Гарнитура (priority 0, latency offset 0 usec, available: unknown)
		headset-input: Гарнитура (priority 0, latency offset 0 usec, available: unknown)
$ pacmd set-card-profile 2 a2dp_sink
Failed to set card profile to 'a2dp_sink'.

PS I’ve tried to clean cache in /var/, I’ve tried to reboot.

1 Like

Could you please post the output of journalctl --user -t pulseaudio -S today ? Change today to the date you tried the last time to connect or try to reconnect before posting the logs, preferrably after having rebooted.

1 Like

Have you may deleted your post because from the logfile the problem was obvious and you fixed it yourself? If so, please withdraw and mark your post as solution of this thread to help people in the future.

$ journalctl --user -t pulseaudio -S today 
Hint: You are currently not seeing messages from other users and the system.
      Users in the 'systemd-journal' group can see all messages. Pass -q to
      turn off this notice.
No journal files were opened due to insufficient permissions.

then I've added myself to that group, but still

$ journalctl --user -t pulseaudio -S today
No journal files were found.
-- No entries --

And then I’ve connected to headphones while the music was playing in Media Player aloud and suddenly the sound came through.
So no, it’s not solved. It will break again and no exact solution is there so far.

well. another flight and it happened again. unusable.