Browser performance and Android App Support Problem

I have recently started using sailfish os on a sony xperia x and, apart from the web browser performance, I am very satisfied with it. is the bad performance due to the sony xperia x or the browser? if i buy a license can i use an android browser? Does it go better then? or should I buy a sony xperia 10 II?
Best regards


With a license you would be able to use Android browsers, but only versions for Android 4.4, since the Alien Dalvik for the X has not been upgraded from its original version.

1 Like


Currently the browser is Gecko version 60, they are planning an upgrade to version 78 in version 4.4.
It should speed up the rendering of websites.

The next SFOS version is not far away.

so would you rather recommend me to buy a newer Xperia or to go with the x and buy a license there? in my opinion the X is basically very nice and compact :slight_smile:

If it’s only browser speed you’re missing currently with the X, you also have the third option to wait for the 4.4 release which will bring Gecko ESR 78 to the native browser

yes, some internet sites report an outdated browser and reporting detected Firefox 60. Others simply do not work . Most problems are with that damned cookie warnings, and still not possible to skip them.
Will this turn better with Gecko 78?

So I have now bought a license, reloaded sailfish os and installed. Then set up the smartphone and logged in with my Jolla account. But whenever I like to download fdroid or another android appstore from the Jolla store, it disappears immediately after installation? What am I doing wrong?

Did you actually install the Android App Support (from Store)?
Also, since it seems to be a common misconception, there is no need to reinstall the OS.

1 Like

yes i did. i can also see the app in the jolla store listed under “my apps”…

Strange… maybe open a separate thread about that issue then.
And to get you some content for it; try installing from the command line with apkd-install and see if it prints something interesting.


There’s a bug which makes icons disappear even though the apps are still there. Not sure what triggers it.

Don’t use Aptoide. It has malware on it.
Use Aurora Store.

Not sure what the best Android browser supporting 4.4 is.

Usually, if you upgrade your phone, Jolla Support will upgrade your license but don’t bet on it.

1 Like

So I have now tested other custom roms and then flashed again with emma stock firmware. After that I reinstalled sailfish os and the error unfortunately still exists. The apps disappear and are not startable. To charge 50 euros for it is honestly not without! I’m curious if the support helps/can help…

You can submit a request here:

I don’t know how and why but now it works :smiley: I chose fdroid classic as the store. why is aptoide officially in the jolla store at all or is mentioned in instructions when you can get malware there?
If you download or catch a contaminated android apk, is the android-free area also affected or is the part isolated from android?

I had the same issue with the disappearing apps. I think a reboot fixed it for me. There is a thread about this somewhere here on the forum. Glad it resolved itself, before you got too annoyed :wink:

Theoretically the malware should be contained a bit to the android container (a lxc container, kind of a virtual operating system, mostly seperated from the rest of your device), especially because android malware would not assume there is another OS to infect. However it certanly can affect everything it has access too, accessible pictures etc. The android security model might mitigate this however. Long story short: I wouldnt try :wink:

There were multiple times it was asked why aptoide is still in the store. I found once where it was asked at a community meeting, where these things usually are discussed wth jolla and they provide answers. You can read the short answer in the minutes, or you could check the long version for the conversation around that.

1 Like

Yes, contaminated Android apps can seriously and permanently damage the SFOS, so that reinstalling is necessary.
But my very bad experience was long before Sailjail and SFOS, so maybe it’s better now.