Browser has problems downloading Mail Attachments in GMail

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.3
HARDWARE (XA2, X10, X10 II, …): XA2 Plus
REGRESSION: (compared to previous public release: Yes, No, ?): i exprience this problem always. never worked.


It is not possible to download gmail mail attachments via the browser - > I always get an XML Parsing Error: undefined entity. Since i have no problems with deskto browsers to access the attachemnts - must be some SFOS Browser issue.



  1. receive an EMail via GMail
  2. Login to gmail via the browser
  3. go to a mail with attachements
  4. try to download an attachemnt.


attachment is downloaded


error is displayed in the browser.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Bug still persists with

User-agent override fixing is enough to fix this:

Wrote testing steps to the PR if somebody want to try. Once this is merged, I will publish this to the user-agent override channel for devices using 78.8 engine. The new user-agent override file will be fetched by the engine after using the browser for a while.

1 Like

@rainemak user agent overrides are not distributed via the package manager but updated separatly from within the browser?

@thigg initial override comes via sailfish-browser package. After that follow up overrides are fetched from a server by gecko. Override updates are tailored from each engine version. Our aim of course is that we have as few overrides as possible.

Landed fix today. After using your 4.4.0 upgraded device for a while you receive new override. I have already received mine.

To be noted that if you have been tampering with CUSTOM_UA environment variable you need to clean "general.useragent.override" line from $HOME/.local/share/org.sailfishos/browser/.mozilla/prefs.js.

1 Like

@AndyWuest can you mark this solved?

1 Like

It took a few days, but now it works :slight_smile:

1 Like