Bluetooth pairing fails between Xperia 10 plus dual sim and carkit (Škoda Octavia 2013), Sailfish 3.4.0.24

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): Sailfish 3.4.0.24 Pallas-Yllästunturi)
HARDWARE (Jolla1, Tablet, XA2,…): Xperia 10 plus dual sim
UI LANGUAGE: na
REGRESSION: (compared to previous public release: Yes, No, ?):
?
Owned a Xperia X before the Xperia 10 plus, which didn’t had issues with pairing to the bluetooth carkit.

DESCRIPTION:

Pairing with bluetooth results in an error with incorrect password/code, which can’t be given/isn’t asked.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. pair with carkit

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Have you tried this?
https://together.jolla.com/question/199216/howto-xa2-bluetooth-connection-to-car/

Can you be a bit more specific? It’s a topic about the pairing doesn’t work and several possible solutions are being presented there.

Try to make your car’s Bluetooth interface visible and search for it in the phone. When you try to connect, the car will request a PIN, but the phone doesn’t show one. Just enter 0000 to pair them.

The usual way is to connect from the car, but this doesn’t work because you cannot enter the PIN from the car kit on the phone - if I remember correctly.

Thanks for the help, this indeed solved it. My car asked if PIN ### ### was the correct PIN on the phone. I didn’t see it or knew how to check, so I just pressed OK and the connection was made.