Bluetooth car kit and receiving calls

REPRODUCIBILITY (% or how often): 95%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes, since spring 2019


No sound over bluetooth car kit on incoming calls. Outgoing calls work and media playback works fine. This behaviour appeared on an update around early summer on 2019. Also, when answering a call, the phone is quite unresponsive, e.g. terminating the call by red button takes many seconds. After hanging up the screen is totally unresponsive for some seconds and often it is impossible to re-establish the bt connection without rebooting the phone.


XA2 dual sim with sfos or any other sfos version since around May 2019 paired to Jaguar XF


  1. Pair the phone
  2. Answer an incoming call
  3. Observe the lack of sound


Working sound


No sound


A workaround is to select the red button on incoming call and call back.

Edit: incoming call ringtone comes through the car audio just fine, the problem appears on answering.


Addition to OP: When answering to incoming call and getting no sound through bt carkit, there is actually no incoming sound whatsoever, even if I try to switch the sound to phone speaker.

Edit: yet more info. I have now observed the same behaviour in context of plantronics bt headset. With plantronics the issue is more sporadic, like once in 20 calls or so, hence mentioning only after I was sure that I am not imagining things. With plantronics, the headset rings and announces an incoming call, but no sound comes out of the headset. Also, it is possible to switch the sound to phone speaker without hanging up. This in contrast to Jag bt, where the phone needs to be reconnected.

This is quite an annoyance considering that the bluetooth worked just fine before sfos update on 2019. After going broken, I think the was third update that still failed to fix the issue. As Jolla is a small company with limited resources, I am already willing to ignore this kind of problems to some extent, like waiting over one update cycle. But three cycles with the result of ‘perhaps fourth is the charm’ is starting to wear my patience. All this at the same time when they pour their effort to stuff like renaming the user nemo, where they and app devs need to rewrite half of the code in order to get to where they already were. This is just sad.

Maybe there is something wrong with the BT-module or BT-blob of the phone you are have in use because you have also problems headset and you don’t mention any other BT devices that could possibly work? I haven’t had any real problems with car kits when using JollaPhone JP-1301 earlier or Sony Xperia X10 lately with two different cars from VAG and the in minor case when the phone didn’t want to automatically connect to the car, all I had to do was to disable and re-enable BT for it to work.

Thanks avhakola, good points. Any idea where could I get access to the bt blob and checksum? As for the btmodule, I will try out the old JP1 and see how it goes. I know the btmodule JLR uses, is not one of the best ones available and it has had its issues with some phone, but these known issues are a stable quantity. If a phone works, then it works, if not, then it does not work, no flipping between the states.

I just verified the bluetooth module in car as functional. I paired an intex aquafish spoofed as jollaC, running sfos to car and receiving calls worked just fine. This matches to what i remember about my XA2 working properly. I am not sure which way the 3.1 was, so it may be either way, but 3.2, 3.3 and 3.4 are bad and the 3.0 was still good.

As already stated, I understand Jolla’s small size and lack of resources, but breaking something already working in basic functionality, and then not bothering to see to it while expending effort on useless stuff. What are they thinking? That is not the way to wind new users, nor does it help with keeping the existing ones.

1 Like

I think the BT-blobs comes from SoC-manufacturers to Sony so I don’t know how to check those or if it is even possible to get the proper checksums for those from anywhere. It has been suggested in the past that you flash back to Android and let it do updates to the blobs, test them working and reflash back to the SFOS after, but it doesn’t help if the module itself is broken or there isn’t anything wrong with the blob and no newer version is available.

I guess I might have a chance if I try to flash v17 image from Sony, as I currently have v16. Perhaps it might fix the gps, too at the same go.

Hi Tomi, me too, with a Sony Xperia XA2 Dual Sim H4113, after updating to Pallas-Yllästunturi 3.4.0, I noticed this:

the bluetooth connection goes into confusion and does not work well, if one of the sims (basically the second, or in any case the one that was chosen as the main one), loses the signal. This with almost all bluetooth devices, but especially with car systems. With only one sim (be it the first or second slot) incoming and outgoing calls work regularly, but it does not connect if I want to hear an audio from my mobile phone to the car system. You should try to have a terminal command, which resets the bluetooth module, or something like that. Because turning off and on the bluetooth does not solve, and neither deactivate one of the two sims and then reactivate it, nor activate and then deactivate the airplane mode.
I also hope that with the next version of Sailfish, we will be able to return to more features. I wouldn’t want to walk around with two phones. :pray: :bowing_man: