Bluetooth audio level

Have the same issue with Xperia 10 & the Bluetooth Speakerphone in my car (Nissan car entertainment system), and also with BT Earpieces. Was also the same with my old X2. It works, but too low audio level for me to hear and the telephone partner also said I was too low. Therefore it can’t be a problem of codecs, but of audio level. Please simply boost up volume!

Q: In what system file is this defined? Please give information how this can be done by small system hack.

I am not sure if this is the same issue, but here goes…

I use my Ford Audio Bluetooth connectivity a lot with my XA2/XA2Ultra, and it works fine 95% of the time. Every now and then, with no apparent reason, the audio volume with music gets capped. Changing it to lower and back to maximum doesn’t help, lowering it to zero and back to maximum doesn’t help either. Restarting the phone helps, only for it to occur at a later point again.

It’s not that big of a deal, but it gets annoying when the volume gets back up and the car audio is set to compensate the volume, hence being quite loud until I dial it down a few notches.

There is no volume control in Deezer, and the Sailfish controls are visually OK; there doesn’t seem to be that “headphones volume warning” with Bluetooth audio, so that should not be the case…

This issue doesn’t happen in every bluetooth devices. In my case, I have three bluetooth devices and volume level is low in only one of them: freebuds3.
If you boost up volume to over 100%, sound is distorted, so that is not a solution to this problem.

Sony Xepria XA2 with Sailfish OS Same trouble with low bluetooth volume… Please fix this soon!

I read very often here about low volume with Bluetooth devices.

So my question is: Where is the volume control for the Bluetooth volume control? What setup file controls this? It should be no problem to write another value into the volume control setup for the BT headsets or earpeaces, I think…

Hey Seven.of.nine,

as far as I know there is only one dirty workaround:
Check for the current connected bluetooth device ID:

pacmd list-sinks

and set the maximum volume to 200%

pacmd set-sink-volume <dev. ID> 131072

where 65536 means 100% and 131072 corresponds to 200%

But there are at least two drawbacks of this workaround:

  1. The device ID changes whenever you reconnect the device (this is why it should be rechecked every time you start up the bluetooth connection)
  2. The sound quality tends to be bad the more you turn it up. It starts clipping somehow. This gives me the impression that wie tweak with the wrong parameter.

Here you find some other contributions to this topic:

Would be great if anybody can help with that.

The thing is though it doesn’t happen on all devices. My earbuds work fine but the car i connect it to has the low volume issue.

Well maybe it is codec related. I have very poor volume with my Jabra Evolve 75 headphone (Bluetooth 4.0 or 4.2, A2DP (V1.2), Hands Free Profile (V1.6), Headset Profile (V1.2), AGHFP (V1.6)).

I also have the same problems with Bose Soundlink Mini II (supports HFP, A2DP, AVRCP, BLE profiles)…

Does this help to find reason?

My Jabra Evolve 75 works alright on my X2+, I can’t complain about the volume.

I only miss the chance to accept, reject or terminate calls from the headset, but this seems to be an issue with all BT headsets on Sailfish

Hey jollajo - wow, that sounds interesting! Do you also have SF installed? Can you still hear music comfortably when turned up to 50%?
I guess this is not an AlienDalvik issue, since the sailfish promo video (showing a guy walking through winter scenery) is also very low…
Is there any hidden parameter in the system to be tuned apart from the standard volume setting? I don’t get any volume warning when turning up on a bluetooth device - is this normal?

Do you also have SF installed?


Can you still hear music comfortably when turned up to 50%?

I can’t see a change of behaviour that depends on the volume.
I also don’t see anything special about AlienDalvik and BT-Audio.
Haven’t done anything special on the phone and also don’t get the volume warning.

What’s special with this headset, if it’s connected to the PC with the USB dongle and the phone, the phone cannot start audio playback. It seems to start for a second and stops again. This happens on native and on Android apps. It seems to me that the headset does not pick up the audio stream (in time) and the phone aborts playback in return.
This doesn’t happen if the headset is only connected to the pone.

Pairing only the phone doesn’t have an impact on that. Always poor volume…

Asking you for 50% volume was ment to be a “benchmark”: With normal wired headphones 50% is normal for convenient listening. With bluetooth headphones 50% is by far too poor.

Well my benchmark is whether I can increase the volume to the maximum level I would like to have. Just checked my ‘standard’ beat-disco mix. Maximum volume was just below the maximum level I can stand. My other BT in-ears are a bit louder, however it’s still alright for me.

I can’t imagine that’s it’s healthy to listen to audio at the given maximum level. So I can’t see an issue in my setup.

Ok, anyhow. My bluetooth 100% volume is on a very inacceptable low level. Is there any idea of how to solve this out there? Will Jolla work on this (it’s not a new issue. I had exactly the same problem with SF3.3)?


Still no improvement with 4.1 on XA2. I have to use full volume of my car audio system and the phone to be hardly able to make a call or stream music or podcasts.


The main question is, where is the audio mixer of SFOS? and where are the level settings of this mixer?
If we would know this, there should be no problem to modify this level settings and increase volume of Bluetooth audio devices.

I assume its pulseaudio that is handling everything. I don’t think there is a GUI for it. And even if you want to use/compile the GTK ones i assume you cant.

1 Like

I hope to find some clear text config file for this mixer, where the level settings are and if I find something, to modify those settings by editor (as devel-su). I will report here if I find something. @ApB: Thank you for the ‘pulseaudio’ hint!

1 Like

I also have freebuds 3, paired on my Xperia 10ii.
And experience the low volume issue when trying to listen to any media content (music, video, recording, streaming video etc).

This MUST be a missing codec issue, since the same BT earpieces work perfectly fine when making calls. The volume on freebuds 3 while in calls is loud and clear.

I hope this will be solved in the final 4.1 version!

1 Like

This issue seems to be fixed with 4.1. At least with a 10 ii.

1 Like