Banking apps on Sailfish OS

Technically my use case isn’t strictly speaking a “Banking app” - only eID and mobile payments. I am not interested in app-based banking whatsoever.

How do eID and mobile payments work there? For ID, I have a gov’t issued card. For payments, I have a bank card (which works in California and Calgary, Southern France and Northern Italy). What would you need a phone for?

1 Like

The problem is there is no way to put my ID card in a reader and tell some website that i’m me. The only “solution” is an app made by the banking cartel. The point here is the remoteness. I’ve never used eID “IRL”, and that only recently even became a “feature”. And i would never.

I pay with card basically all of the time; but good luck accepting cards as a private citizen. Or just take small businesses having gone on the road (e.g. a farmers’ market) with a fixed card terminal back at home… then you kind of need this app. I of course carry a bit of cash along with physical ID and cards, but it’s not seen much use in recent years.


Exactly what I’m talking about here. Swedes don’t have much choice these days.

Hmmm. Don’t get it. What reader releated to what website? I pay with credit card (Master Card) on websites all the time. Aliexpress, ebay, random DIY synth parts site. I have to authorize with the usual pin/and or TOTP/or failback SMS (!). Of course, paypal and co. are fairly low friction. I’m assuming this is some Sweden only thing? I noticed in Denmark 2 years ago, that there was a payment system I had never heard of and it was the only one available for somethings (at a camping site!). So, the merchant lost a sale. I thought that odd in a touristy location?!

I use cash all the time. I always have some in a pocket. Always. If I forget anything else (bag with wallet/mobile), I can still buy a beer at the gas station :slight_smile:


What i wrote about IDing online was mostly unrelated to payments. It’s about online gov services and such. There physical ID is unfortunately powerless.

However; most banks have this shite app as the only 2FA for cards.

Denmark has always been weird. I remember ~15 years ago when they only accepted Dankort in many smaller stores.

Ok, got it. The Germans (forgive me for generalizing) are still hampered by provincialism. Since no two city-states can agree on common standards, you just get in line and wait your turn :slight_smile: If you can get a bus to the relevant authority (!). At the current rate of development, the apocalypse will have come and passed before you can get anything done otherwise.


I was about to confirm your experience since QR codes didn’t work for me recently, but wanted to verify first, so logged in to Nordea using Nordea ID and QR codes and it worked. This time.

Isn’t the latest version of Nordea ID from Aurora Store v2.6.0? Using SailfishOS v4.5.0.25.

And yes, I intentionally try to use the ‘Code calculator’ device whenever possible.

I remember visiting Germany a few years ago (before Covid) and attempting to pay with my contactless card, which had been common in the UK for years. They had all the hardware already installed but had genuinely never seen such a thing and were flabbergasted when I simply touched the card on the reader instead of inserting it into the chip reader device. They were even more astonished when the amount instantly appeared on my watch (thanks to Amazfish) before the register even confirmed the transaction as successful. :grin:


Heh. I’m the sort of person that HAS a contactless card, has affirmed it works (drinking beer at FOSSDEM I just waved the card in the air which made for an amusing bank statement), but generally (today), insist on inserting the card, and entering a PIN. I actually asked my bank if they could issue you a card WITHOUT contactless foo. But, they declined. All my watches break in short order. I am a watch killer.

1 Like

There is an easy solution to remove contactless payment: take a torch and a needle.

With the torch find the “band” and make a hole in. You have now a contactless credit card. I do it on all cards I own :slight_smile:

with n26 i can disable contactless payments in the app, maybe you can do that too

True, true! I’m so busy prototyping with soldering iron in hand, i forgot the most obvious solution!

I will in fact try to find my way through the labyrinth since I wanted to adjust stuff for the summer vacation period. It’s just that the deutsche has a hell hole of a website. But, ‘selber schuld’ I guess :wink:

Name of the bank: ASN Bank (the Netherlands)
Name of the app: ASN Bank
Version of the app: 1.19.1
To what extent it works (see scale at the end of the wiki-page): A1
Which SailfishOS version you are using: (also worked in and
Which device you are using: 10 III

What is MicroG in sense of Sailfish?

MicroG (typically styled as microG) is a free and open-source implementation of proprietary Google libraries that serves as a replacement for Google Play Services on the Android operating system.

That sums it up pretty much.

I’m no developer, just an end user, but if I had to explain with examples what MicroG is, it’d go like this:
MicroG can be used as a more privacy friendly method to use apps relying on proprietary frameworks made by Google (allowing you to use, for instance, a navigation app without sending your location data to Google), also to bypass certain security methods such as SafetyNet (allowing you, for instance, to play Pokémon Go and use many banking and streaming apps relying on it).

Basically it’s a swiss army knife of open source goodiness allowing you to have a cake and eat it too, which is all too rare nowadays! :hugs:



  • Spain
    • Banco Mediolanum
      • ?
      • A2 Juanro49 20240410 (no notifications)
      • A4 in all Sailfish 4.6 EA versions (force close when it starts)
Name of the bank: Erste Bank (Austria)
Name of the app: George
Version of the app: 24.10
To what extent it works (see scale at the end of the wiki-page): A1 (except qr code scanning and application must be installed either from huawei store or play store)
Which SailfishOS version you are using:
Which device you are using: 10 III
1 Like

I don’t want to contribute to the wiki yet, because maybe there is a way to fix it.
I can’t log in into Polish version of ING mobile app on SFOS 4.6, installed using Aurora Store.

It says the app has been installed from unknown source.

This has been an issue in 2022, but there has been a workaround made GitHub - enedil/fix-ingmobile-on-huawei: Spraw, by Moje ING działało na telefonie bez Google Play
It was possible to do this fix on SFOS, not using the script unfortunately but at least manually. Later ING has quietly rolled back this check, and it simply worked installing from Aurora store.

I haven’t used ING on SFOS for a few months and when I wanted to go back the issue is back, but that fix no longer works. Installing the app using Android’s pm install-create -S 122567816 -i returns Java error when I try to do it.

Exception occurred while executing 'install-commit':
java.lang.NumberFormatException: s == null
        at java.lang.Integer.parseInt(
        at java.lang.Integer.parseInt(
        at android.os.BasicShellCommandHandler.exec(
        at android.os.ShellCommand.exec(
        at android.os.Binder.shellCommand(
        at android.os.Binder.onTransact(
        at android.os.Binder.execTransactInternal(
        at android.os.Binder.execTransact(

Does anyone know what changes to have been made in newest SFOS release?
Or has anyone found other way to workaround app detecting not being installed through Play Store?

This shit is making me more and more furious. This is what our governments (or EU/UN) should have solved many years ago.

Why are we even letting the banks fuck us like this? It should be the easiest thing in the world to force them to make all their apps, sites and everything in between, platform independent.

Damn, demand from your politicians that they fix this! :angry:
And not in 20 years… NOW!