Banking-Android App doesn't work, because device is rooted

Hi, transferring apps from my actual Android 11 smartphone, I encountered another problem:

I installed via Aurora-Store the App “S-pushTAN” as a 2FA to login on computer.
Installation worked, but when I open the app, I get the error message:

“Security Advice:
your device is “rooted” …not safe enough for using.”

Is there an easy way to fix that? My Alternatives are:

  1. Use an existing Android-Tablet in future to authenticate.
  2. Talk to the bank for another option.


1 Like

Please search before posting.

1 Like

To be slightly more helpful, it seems that some banking apps now work on Jolla’s newly signed Android image and some don’t. On the previous unsigned image the vast majority did not work at all. For me, in the UK, on X10 III, the Lloyds business banking app works fine, but the Santander one does not. In general banks are tightening the security for their apps so they are becoming less tolerant of rooted phones, AOSP Android, etc. You may find you can still use mobile banking via the web browser with your bank. I can do this with Santander, although it always serves up the desktop site rather than the mobile site which is a bit of a pain.

The app you mention is issued by german Sparkasse, which usually allow the chip tan method. As no hackable device with internet access is involved, this is more secure anyway.
However, you have to pay for the device, something like 15 euro.

Thanks for your answers. Good to know that some apps are working with other banks.

I’ll call the bank, what the costs of a chip-card will be (luckily I possess a “ReinerSCT” cardreader).

Have you got Magisk installed by chance? Or similar app? I’ve just found that after install Magisk one of my banking app suddenly started claiming that phone is rooted.

1 Like

No, I have not, thanks.

Hey there , for general info, on my xa2 latest build all my banking apps work properly , thats Rabobank Netherlands and BCA Indonesia ,but making use of MicroG, maybe that makes the differents, have a good Sunday all.

1 Like

With the update I could install “S-PushTAN” over Aurora.


Can confirm that previously non-functional “secure” app now works with microG an


Just tried the banking app TEO of the German bank Sparda with It used to claim that the device was rooted but now works (without gapps and without microG).

@Jolla thanks for the fix.


On (first one I tried), ING Bank Romania works fine (albeit without fingerprint support), while Orange Money Romania complains about the lack of Google services and Revolut didn’t want to work because of the version present on Aptoide (it said it needed an update).

Definitely better than expected, though :slight_smile:

@johnflorin Do you have ‘Vanced MicroG’ installed? This replaces some online Google services that some apps need. Maybe you want to install ‘MicroG’ and try again.

edit: You can download Android apps from Aurora Store without Google account. They are more current.

1 Like

Thanks for the suggestion, but the ING one is the main app I actually use for banking, so it’s fine as is :slight_smile: (this is a secondary device, alongside an iPhone)

Got Revolut to work from Aptoide without any other changes, it’s possible they updated the version there in the meantime (although it’s still a version that was released earlier than my previous attempt :person_shrugging: ).

One thing to take into consideration is that since Revolut’s authentication wants you to click on a link from an e-mail they send which takes you to the app, the e-mail address has to be accessible from the SFOS e-mail client. I had previously used Gmail to register for Revolut (and have no plans to add Gmail to SFOS), but switched Revolut’s account details to my own-domain e-mail address, after which I could click on the link and surprisingly enough be redirected straight to the Revolut Android app from the SFOS e-mail client, so kudos for that, didn’t expect it to work :slight_smile:


Happy to report that Banca Transilvania’s NeoBT mobile banking app also works by default in SFOS. I also tried their BT Pay app, which has other features besides the obviously non-functional NFC payments, but it errors out immediately.

1 Like