Aptoide doesn't work after upgrade to Kvarken (4.1.0.24)

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24
HARDWARE (XA2, Xperia 10…): XA2
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Aptoide starts but always fails to search for apps with an error that says “everyone is trying to install apps at the same time.” Unfortunately this “user friendly” error does not give any helpful information, such as whether DNS failed, or routing failed, or the host was unreachable - so I have no idea whther there’s actually an overloaded server or if there’s some other error.

It’s been a couple of days now with no observable change in behaviour.

PRECONDITIONS:

Remove old aptoide store (green logo), marked obsolete, install orange aptoide logo store from Jolla Store.

STEPS TO REPRODUCE:

  1. Launch aptoide
  2. Select “Search”
  3. Enter anything at all into the search field and execute.

EXPECTED RESULT:

A search result is returned, with or without any hits.

ACTUAL RESULT:

An error suggesting that the service is overloaded appears.

ADDITIONAL INFORMATION:

Welcome to the forum, it does work upon my XA2 but constant adverts for say TikTok needing 5 seconds to dismiss is a pain. Why not install Aurora store from F-droid and log-in as incognito:

I’ll give it try, I reported the bug because it’s the store that’s found by default.

You might want to stop these adverts in the app’s permissions. I did so because I was annoyed by them, too.

1 Like

Figured it out. I had google play services and google play store (non working) left over from some experimentation pre-kvarken. They didn’t stop the old green-branded store from working but they did break the new one. Removing them did the trick, in that aptiode can now talk to its servers.