Appsupport missing after fresh install

Hello everyone,

I just finished flashing sailfish os on my xperia 10 III. However, I am unable to find the app support service anywhere. Could you please help me with that ?

Have you bought a license (if it is a new device)?
Then it should be readily available in store.

Yes I bought the license and I am unable to find it in the store. in 2021, I bought it for the xperia 10 and I didn’t have any issue.

Just to clarify… you mean for this phone, right?
And you are logged in to the account you bought it for?

To be clear:

in 2021: I had a xperia 10 mk1 to which I bought a license and I didn’t have any issue. I don’t have that phone anymore.
This evening: I got a xperia 10 iii to which I bought another license and installed it. Yet, I cannot find app support.

Both purchases were done from the same account.

Then i can only recommend you contact support.

Are you perfectly sure you are logged in with the correct Jolla account?

Yes 100% sure it’s the correct one

@Youness91 Try to delete the Jolla account on the new phone, reboot phone, and then create the Jolla account new and be careful for typos. It can be (and happened to me and others) that an old existing Jolla account is not recognized correctly by the Jolla server after a purchase, but after deleting the old account on the phoe and creating it new with the same existing credentials it worked.

If it doesn’t help, print (save PDF to file) your purchase data with all numbers and send it to support and include the IMEI number of your new phone and send both to customer support.

I just tried and it didn’t work. When using the credentials, the phone already recognizes that it’s an existing account. Also, Knowing the actual situation of Jolla, do they even have a customer service still running ?

Maybe the internet address has change because of the renaming of company. I’ll have a look and report here soon.

edit: I think it’s here:
there log in with your SFOS credentials and then click ‘purchase history’ → at the last purchase click on ‘view’, there you can read your purchase id, payment method and so on.

In the bottom right corner is: Contact us:

Try to send everything to this address with your question.

Thank you. I opened a request there. I noticed something in my purchase history. See the image below:

It shows paid and not completed as for my previous purchase

Good. I think it’s in progress and will be done soon. If not in a few days, click on ‘View’ on the upper line, safe the upcoming screen to a image file and send it to support and ask them why it’s hanging.

I flashed again SF, Updated my Jolla account details and changed the password. Didn’t solve the issue. From Jolla’s side, no update and no answer.

Update: Solved finally. Turns out that my username (with which I bought the licenses) was disassociated from my email address (used in my phone)

Thank you all for your help.

1 Like