Applications offline via mobile data but work over wifi

Hi guys,
I have had a recently an issue with the Opera browser on the latest SFOS. It stopped working over the mobile network but worked over wifi. I thought I solved it but it came back again and this time other applications also say they are offline while on the data plan(unlimited). The stock browser works every time while other apps can’t connect. Is there a firewall settings or something to sort this out? The phone is XA2. Thanks

I do have the same issue with Zoom for some reason.
And on the opposite, some other apps (Joplin, Aptoide) will work over 4G but not over wifi !
I also have a XA2, and I’m not sure when these issues started, but very happy if somebody has a clue.

It sounds like a bug. Unfortunately there are probably lots of them so the more serious will get a priority.

Did you check the Android permissions?

Hi, Android support is on but there is nothing about permissions for connectivity. Opera says that a website is not accessible and was probably moved to another address. It seems that the last SFOS 70MB update messed up with the carrier mobile data settings as it shows me sometimes limited connectivity.

This issue?

Yes, I work in the area where the signal for 4G is pretty poor including the 2 and 3G. It works now a bit but might stop working again.