App.luca-app.de in native browser cannot use camera

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.3
HARDWARE (XA2, X10, X10 II, …): XA2
UI LANGUAGE: Ger
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION:

https://app.luca-app.de/webapp cannot use the camera.

Situation: Wanted to go to the star dome and had to register with Luca, but I don’t want to install it. Corona Tracing app from F-Droid was not able to scan the QR-code, so I tried the camera to enter the webapp.

PRECONDITIONS:

open webapp with native browser. Testers may need to fill in fake data first, if they have never used it before.

STEPS TO REPRODUCE:

  1. Open https://app.luca-app.de/webapp in native browser
  2. Button „selbst einchecken“

EXPECTED RESULT:

Camera is started on website to scan QR code

ACTUAL RESULT:

Website shows error: Camera not supported in this browser.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

2 Likes

I tried using wise.com which requires photo id for large transfers. Although I didn’t get a warning like here, I also couldn’t take a photo within the web browser. I had UI, clicked and nothing … 4.3 on Volla in my case.

1 Like

As a workaround, you can scan the qr-code with the sfos-camera app and then open the link in the browser.
A second, very reliable workaround is ignoring the luca code, or pretending having logged in with CWA. They may even offer solid paperworks on request. Luca is really something people shouldn’t use, and it will most likely be obsolete soon anyways, since most of the German counties are currently canceling their contracts with this crap stasi-style company.

4 Likes

I have a similar problem here.
If I want to use the page https://schnelltesttest.de in the native SFOS browser, the message appears: “Unfortunately, we could not get access to your camera. Please allow this access so that you can scan your code or enter the code yourself .”
On the other hand, it works with an Android browser (Kiwi) under SFOS.

2 Likes

With 4.4.0.58 sailfish browser can now access both cameras from Xperia X. Thanks!
But there is still one problem left, the cam doesn’t focus the barcode.

1 Like

Thanks for checking this @s_mario. If the original bug here is resolved (which it should be with 4.4.0), but camera focussing is still an issue, would you be able to create a fresh bug report about it please?

@dexic, if the original bug is now fixed, would you be able to mark this issue as solved please?

It just makes things much easier to follow if different issues are discussed separately when it comes to bug reports.

2 Likes

At least for Luca, the problem is now obsolete since they recently announced to cease operation

4 Likes

@flypig Thank you for your feedback.

I created a bug report to the problem of the non-focusing camera in web-apps.
https://forum.sailfishos.org/t/camera-picture-in-web-apps-is-out-of-focus/11674/2

Sorry, that it took so long.

Thanks for doing that @s_mario. It does help to things clear, so I appreciate it.